Zigbee routers changing device ID (5 times in 5 mins)

What would be causing my zigbee routers to be changing zigbee device ID's 5 times in 5 minutes.

This is a screen shot of 6 minutes, and it has my XBee router changing so fast, it can't keep up. All highlighted is the XBee. I've removed the tradfri router that was also doing likewise.
It's causing mayhem in my zigbee network. This is a C-5 hub.

I've tried rebooting many times.
I've tried shutting down the hub for >20 mins and removing power supply.
I've tried disabling and re-enabling zigbee network.
I've removed and re-added the zigbee router. Checking settings.
I've emailed support. Nothing yet, but it's the weekend, so no biggie.

In the time taken to type this post, it's changed 3 more times. I'm on the latest platform.

Edit, for clarification: I only have 1 XBee, and yet, each yellow highlight is the same Xbee with a new device ID.

What's in parens after the device name? This is one line of a log. Why do you think the device's zigbee id is changing every 5 minutes? Do you have a log showing that?

What you are showing here is the signal strength of the last hop. This is always changing due to multiple paths back to the hub, interference, people moving around, doors closing, etc. It’s not something to be concerned about. Those are very good numbers btw.

Why and how are you assigning the RSSI to the device label? You have an app relabeling your devices with tje RSSI value dynamically? Uhm...that's absolutely crazy. The amount of overhead that must be creating....you're suffering from a lot of slowdowns, aren't you? I wouldn't be at all surprised if you were. The number of database writes that must require has got to be staggering.

1 Like

That’s just looks like the zigbee log page.

Yes, thanks Ryan. I do know how to read the zigbee log page. The device ID also changes on the device page. I'm talking about the 4 digit zigbee device ID. Each time the device ID changes, it produces a new "device" on the zigbee logs. I'm highlighting the new devices, not the RSSI from the last hop.

The reason the device ID doesnt say "XBee" is it's changing so fast, the zigbee logs cant keep up.
If, and it's a big if, the device ID remains unchanged for a few minutes, the device 4 digit ID will change to XBee. See image below for just one example.

here is the device ID from a while ago. 2C4B

and here you can see that 2C4B is the XBee, and eventually it changes to XBee.

It's changed 13 times in the last hour.

Yes, I'm not changing the device ID. I dont have an app. It's HE that's doing it. I'm not sure why. I want it fixed. Nothing to do with me.

Correct, it is staggering, and I'm trying to get it fixed. My other hub (C-4) doesnt do this

It's got nothing to do with me, at all. I'm not the only person to report it either.

See here

Of course, it is the zigbee logs page. It's showing that the Xbee has changed it's device ID 13 times in the last hour. I'm not referring to RSSI for the last hop at all. That's irrelevant to this discussion. Each yellow highlight is the one device that changes it's device ID.

Then show that. Why just the header?

Because it has my kids names in the logs!

Will it help diagnose the issues?

Just as an example, my Xbee has changed again - I repeat - not by me.

5 mins ago, the device ID was different to this.

I see, just one XBee I take it. Did you try a soft reset and restore?

The zigbee logs?!?


Yes. Many times. See OP.

Sorry, I read it earlier, but apparently missed that. I’ve only seen that happen on SmartThings after a power failure. It’s like it’s constantly leaving and rejoining the network.

1 Like

What does your Xbee report in the child/routes table? If the age is 6 or 7, it's going to get a new ID cause it's about to lose it's association with the hub.

Have you confirmed the setting on your Xbee match those in the Xbee thread? Especially JV. Have you tried re-flashing the Xbee?

Since that's a user controllable device, I would look there before tearing your hair out anymore on the hub, which you seem to have thoroughly debugged.

Thanks for the help.

Here are the zigbee logs, without names. Yellow are Xbee.

I just thought of something...if you're using the default python files for the xbee, doesn't that battery report every 5 minutes to the hub?

Yes, the same was occurring with a Tradfri router (changing device ID regularly) that I recently attached to this hub. I moved it from my other hub, because this hub's zigbee was playing up - probably due to this. I've since removed it, as I thought it may have been caused by that. Alas no.

I'd still try re-flashing the firmware on the Xbee and setting that up again.