Zigbee RGBW bulbs (Innr) – what am I doing wrong?

I’m fairly new to Hubitat but have already successfully paired over 30 devices (mostly Sonoff switches and sensors using the Oh La Labs drivers) without any significant issues.

Now I’m trying to add a Zigbee RGBW bulb. I want to connect this directly to the C-7 hub network, not via a Hue Bridge or anything, because I don’t envisage ever having more than one – max two – smart bulbs (all my other lighting is/will be regular bulbs on Zigbee switches).

I researched best colour bulbs for Hubitat, but most of the recommended ones (like Sengled) aren’t available here in UK. So I bought the inexpensive “Cskyzk Zigbee Smart Light Bulb RGBCW” from Amazon because it is advertised as working with SmartThings, Alexa, Philips Hue, etc so I figured it should be ok with Hubitat. It paired immediately but I couldn’t manage to get any driver to work with it. One driver could turn it on but not off or anything else. A different driver worked to select the colour but not to turn it on or off! I eventually returned that bulb to Amazon, figuring that it was non-standard and incompatible.

After further research, I found the “Innr Smart Bulb Colour E27 RGBW” which, although twice the price, I at least felt reassured it would work since it’s included on the Hubitat Community Device Drivers (AKA Compatible Devices Wiki) list. But again, this one paired straight away yet I can’t find any driver that will get it to do anything at all!

Both bulbs auto-detected as Advanced Zigbee CT Bulb, but I also tried:

  • Advanced Zigbee Bulb
  • Advanced Zigbee RGB Bulb
  • Advanced Zigbee RGBW Bulb
  • Generic Zigbee Bulb
  • Generic ZigBee RGB Light
  • Generic ZigBee RGBW Light

There are people on this forum saying they are using Innr bulbs with both the native generic and advanced drivers, so I feel like I must be missing something. But what?! Any ideas?


View product listing on Amazon UK

Are you clicking on "configure" after you save the change to the new driver?

2 Likes

Yes. Each time I select a new driver, click the Save button, then hit Configure. I'm already used to doing that with the other devices I have added so far. Is there a particular amount of time you should wait for configuration to be completed?

Not really - You might try setting it on "Zigbee Advanced RGBW", saving, hitting configure then maybe rebooting and see what happens. I think the Advanced driver is what you want.

There are some here from the UK that have Innr bulbs like @BorrisTheCat I think.

3 Likes

Yeah innr are I think the best brand I have used, they are 3.0 and have really utilised that with some advanced features. There is no issues having them on you hub unlike the old ZigBee products/ hue.

For driver you need

  • Advanced Zigbee RGBW Bulb (hate that they call it bulb :see_no_evil:)

Save the driver

Then put in the preferences and hit save preferences.

Open the logs and watch when you hit configure. The lamp should dance then turn blue and you should get a confirmation in the logs of finished testing.

3 Likes

Brilliant! Thanks for those quick and helpful instructions, BorrisTheCat, as well as the welcome reassurance that I've made the right choice in going for Innr.

I don't think I would have hit upon this sequence of steps without your help. Especially because I did what I thought was a full reset then followed your instructions, but nothing happened. No dancing light. No blue light. Notification for options testing started but no subsequent notification for options testing finished.

So I decided to swap it out for the fresh unused bulb (I bought a 2-pack) and try your instructions again. Worked perfect first time!

Looks like I've messed something up with the first bulb through all my fiddling. But I've no doubt it will work fine once I manage to do a total remove/reset. Anyway, I have one fully working RGBW light and that's all I need for now. Thanks again!

3 Likes

Just one side question BorrisTheCat: the Advanced Zigbee RGBW Bulb driver doesn't seem to support Presence. Do you know if there's a way of implementing that?

I have Presence enabled for all my contact sensors, motion sensors, buttons, switches, plugs and repeaters, thanks mainly to the Oh La Labs drivers of markus, and it's a feature I'd find super useful to have on every device.

No. Not unless you write your own driver.

1 Like

As @aaiyar says not unless you do your own driver, but honestly you don't need it. Presence on those drivers is for devices which drop off and don't report, I have never had a issue with any of my 3.0 lamps.

1 Like

Wait....what so ZigBee 3.0 are fine on the same network and play nicely ?

I've been wanting to get rid of hue and I have all innr bulbs

Yeah never had a issue with 3.0 lamps they should fall back to 1.2 HA which they seem to. The anecdotal evidence suggests that because they are 3.0 they have be be capable of handling the traffic correctly where as ZigBee LL lamps seemed to never be built to handle anything more than light messages so they fell over when doing more. I now have two hubs one with old lamps on and they work perfectly never had a issue since and the other hub has all ZigBee 3.0 lamps switches ex and all working perfectly.

2 Likes

I did not know that. Can dump my hue then

Download the Hubitat app