Zigbee Pairing: The device join failed and was not added to your network. Make sure the device is compatible before trying to pair the device again

@mike.maxwell I have a Linptech Presence Sensor that falls off my C8 Pro zigbee mesh from time to time. When this happens I put the hub into Zigbee pairing mode and reset the Linptech device so it pairs and falls back into place. The past few times I went through these steps, I get the following errors in the log even though the device re-pairs successfully.

I've had one of these running on a C8 for several months now and it hasn't dropped off the network, also I removed it and re-joined it this morning without any issues in the logs.
That message is issued when a device tells the hub that it's leaving the network, however no device that i've ever tested issues more than one of these messages when it leaves the mesh, so i suspect some intermediate router device isn't receiving the ack for this payload from the hub and is sending the same frame again and again.
I might have a look at the parent router for this sensor, and if its a direct child device maybe look into the zigbee power settings .
I can't think of any other reasons for this.

1 Like


Mentioned here too.

1 Like

I had the same thing happen with a Linptech Presence Sensor that added and work great on a C-8 for over 30 days and then stopped working. Trying to re-add it back to the C-8 got the same results you got. I ordered a new one with the same results. I even tried to add being within a couple of feet of the hub and it did not work.

I was buying a new C-8 Pro in the meantime and got the same results. Luckly I have a C-7 as well and was able to add it there with no issue and using Hub Mesh for my automations.

Another user here had the same problem and got it added to a C-8 by rebuilding his ZigBee network 2 times. This makes me wonder if I have another ZigBee device in the ZigBee mesh causing the issue.

1 Like

Have you tried a hub shut down/pull power/30s/restore between pairing attempts? May not help, but won't hurt (other than the repeated disappointment.) :wink:

I've had six of these on my C7 for months, one of them recently would stop reporting. In my case, a reboot of the sensor (pull/restore power) was all it took to get it back to normal. They were are connected directly to the C7 the last time I checked. Anyway, I was busy and just put it on smart splug and set an automation to turn the plug off/wait 10s/on weekly at 3am. No issues since. It was supposed to be a short-term bandaid, but was 100% effective and I just forgot about, frankly, until I read post. Probably will leave it that way, don't feel like going down the troubleshooting rabbit hole. :slight_smile:

Funny story, I saw the same messages this morning - exactly 30 of them, all within 1 second, except that hub (also C8 Pro) wasn't even in pairing mode. Happened within a coupe of seconds after a very brief power outage (hub is on battery backup), but none of the zigbee devices have fallen off the mesh.
Would be really interesting to figure out what rogue device was sending those messages!

I don't think it's a 'rogue' device. I think it's a normal message that got elevated to Error from something less visible... Info, for example.

1 Like

I'm getting this message randomly in my logs. A manual pairing attempt doesn't find anything to pair, so I'm not sure what's going on and why I'm getting this.

1 Like

My experience with multiple Tuya Motion sensors from China. One worked well, the other would not stop flashing blue. No 'messages' were getting to and from the new one. I tried everything and finally found some advice and figured out some. This is about the Tuya ES0202 mini sensor.

There are several versions of the driver for this. The latest is updated as of 6/14/24. Apparently sometimes they change the mfg code and the driver has problems with it. I was running a 2023 version of the driver with the one which works. Downloading the new driver, it's title was the same which was problem $1. On 'pairing' it picked up the old driver and not the new one. But alas, figuring out which was old and new with the same name and then assigning the new to the new sensor did not work either. Logs showed "the device join failed..." still.

Then I saw the suggestion to 'rebuild the Zigbee network TWICE and then power down the hub and re-pair. Shocking, I did that, paired and the flashing blue light stopped on pairing. Wow. Works like a charm now.

1 Like