Zigbee outlet incorrectly identifying as multi-endpoint device

So far 2.3.8 is working very well on the C8p. Thank you Hubitat team. :slight_smile:

With that said I have an off-brand outlet the reports oddly. It isn't a major issue, more of a call to understand the device.

I have been testing these outlets with a C8p. At first I paired them with firmware 2.3.6 and they came up as a generic multi-endpoint switch. I could not control them from the device page. I switched the driver to a generic outlet and it worked fine. Then I had some Zigbee issues on 2.3.7.

With the hub now on 2.3.8 Zigbee is working well and I paired the outlet again (after a full reset). It again came up as a multi-endpoint device but this time it worked. Great.

My question is, since it is reporting its configuration wrong is there anyway I can get it fully setup as it should be. For example, since it is listed as a multi-point device the driver creates a child device. If I switch it to a generic outlet is it possible to remove the child device?

It not a big deal but it can get confusing when it shows up in things like the Rooms setup.

I've written my own virtual drivers for some custom apps but never for an actual device. I don't understand the device fingerprints and all that fun stuff. Here's how it shows up on the device page:

image

image

Without writing a custom driver is it possible to drop the child device?

Switch to the "Device" driver, run the command to delete all child devices, switch back to the driver you believe should work, run the "Configure" command, then see if that all works.

Oh, neat trick. That worked.

The funny thing is it now shows a power state. It doesn't do any power monitoring. :smiley: That's not an issue, I just wanted to get rid of that child device.

Thanks!

image