Zigbee Lamp only reachable via group but not directly

So I'm using large amounts of these lamps in my house:
They connected to HE via Zigbee like a charm when I configured them as "Generic Zigbee RGBW lamp". I connected several of them as groups to be able to control whole rooms as one.
A few days ago I wanted to build new groups and change the color of single lamps but they did not respond. That confused me, because I still could switch them on and off and change the colors via the group device.
Question is: Why did HE lose the connection but on the same time it didn't? Can I reconnect the devices without deleting and connecting them physically?

It shouldn't have. After you control the light as a group, you still can't control them individually? Controlling the group sends the commands to the individual lights, so if the group works, so should the individual lights. There is no reason that they shouldn't.

What it sounds like is a mesh problem. What other Zigbee devices do you have on your mesh network?

Hi Ryan,

no, I can't control the lights individually after controlling them in a group. I already heard things about group messages being broadcasted and not sent to a specific device. Does it have something to do with that?

Currently I've got 33 of those lamps connected via zigbee and 14 other devices connected via ZWave (which all work like a charm).

Because another thread suggested that it could be a problem with the zigbee frequency to close to a wifi frequency, I switched the zigbee channel to 25 (from 20) shortly after my post. Until now the "disconnected" lamps are still not reachable.

There are a lot of devices that don't support zigbee channels 25 & 26. Also, from the perspective of WiFi interference, 20 is about as good as 25.

Finally, I just moved one of my Hubitats from zigbee channel 23 to 15. While some devices changed channel on their own accord from 25 to 15, there were many others that had to be reset and re-paired.

1 Like

Thanks for the info. Some lamps seam to work after the switch (still the same ones as before I guess). So I think theydo work with channel 25.

Side note: The HE is closely to the same spot as when I connected all the devices, so range shouldn't be an issue.

As I asked above, what types of devices are these (Brand and Model), please?

I don't find your question asking for brand and model. As I linked above the lights are from Zemismart. The model name could be "ZM-DL-01" as far as I see.
Here is the endpoint data from HE:

  • endpointId: 01
  • application: 01
  • softwareBuild: 1000-0001
  • inClusters: 0000,0004,0003,0006,0008,0005,0300,1000,0019
  • outClusters: 0019
  • model: LXT56-LS27LX1.7
  • manufacturer: 3A Smart Home DE

Another side note: How would have thought: Power cycling worked to get the lights to reconnect to HE. Still unsure if the problem were the lights or HE...

And you have nothing else on your zigbee network besides these lamps?

Nope. Those lamps are the only zigbee devices.

And you can't control any of them individually but you can via a group? Where are you trying to control them? A dashboard? A rule? The edit device page?

I wonder if his Group is using Zigbee Group Messaging, instead of addressing individual bulbs? That might explain the behavior being seen. Just a guess.

Some of the devices react to my direct commands, but some don't. Im trying it via dashboard, directly in the device and via rules. I switched the rules to work with the groups for convenience as I can easier add or remove devices that i want to have controlled by the rule (e.g. creating a group with all lamps of the bed room instead of having the in there one by one)

I did power cycle all the lamps which helped to reconnect them all. That was 3 days ago. At this point 7 of the 33 lamps are "disconnected" again.
I think I'll try to power cylce those lamps specifically to make them reconnect to the hub again. I hope they realize there are other lamps around them to connect to when I do this one by one.
I'll write again if I know more.

That is my current routing table for the lamps.
Can you guys tell me what the entries mean?
IFAIK The "Neighbor Table Entry" list should be the directly connected devices
the "Route Table Entry" list describes which devices are not directly connected to HE and which device they use to communicate to HE.
But I don't understand those entries like this one:
status:Active, age:64, routeRecordState:0, concentratorType:None, [Lampe Kinderzimmer 2, A8CA] via [Lampe Kinderzimmer 2, A8CA]
The "Lampe Kinderzimmer 2" which means "lamp childrens room 2" is connected to itself for meshing purposes?

The hub is only capable of connecting 32 Zigbee devices directly. To go beyond 32 you need repeating devices. Try turning off a couple of bulbs and leave them off. Then do a repair by shutting the hub off for 20 minutes from the settings page. After 20 minutes power the hub back up.


Good tip, will try that right now!
I didn't knew about the device limit.

1 Like

Neighbor table entries will contain only routing-capable devices that your hub will use to communicate to the rest of your network.
The Route Table Entry is a cache of the output from 'route record request' broadcasts; these entries are derived from the reverse source route to a target device-- it will contain the last hop router in the path (the 'via') which the target device used to reach the hub in response to the request broadcast. So an entry that showing 'device x via device x' means that device x was the target of the route request broadcast, and it is also a neighbor router to the hub.

All your neighbor table entries show good RF links except for those with outCost:0 (devices 5908 and 5BB8). Zero here means that no link status cost is being received from those devices: they aren't telling the hub how well they are receiving on the link, even though the hub is reporting a good cost figure based on its reception from them. The good LQI figure and inCost for these entries are based on the hub's reception quality on the link, not the neighbors capability of hearing the hub; so a good LQI on these links doesn't mean that these routers are actually capable of forwarding frames to the hub. Maybe there is something attenuating or reflecting their signal or some difference in antenna orientation that could be causing the problem?


Having this same issue with some of my Commercial Electric zigbee downlights. I have ~30 of them on a dedicated hubitat hub along with their corresponding zwave wall switches, and 3 Ikea repeaters around. They were working well but a few days ago lost individual control, but group control works as this thread. I do have Zigbee Group Messaging enabled. I can't control them individually via rules or the device page.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.