Zigbee Humidity & Temperature Sensor

Hey i'm trying to get this Indoor zigbee thermometer working what I actually want to do is when humidity drops below 50% to turn on A zigbee outlet that is connected to a humidifier but for some reason it's not working I tried with the temperature as well

https://www.amazon.com/dp/B0B5LMKXJ7?psc=1&ref=ppx_yo2ov_dt_b_product_details

It's already starting out below 50 (it's at 30) I have it on change...

Looks like you didn't save that Basic Rule, or deleted it, because the "In Use By" section of the device page (highlighted below) indicates it is only being used by Dashboard, and not any other app.

BTW, if you had saved that Basic Rule, it should have worked.

1 Like

i have tried Rule Machine still cant get it to turn on the outlet when humidity is below 40%

Apologize I uploaded the wrong screen shot

If you click the run action what does it say in the logs?

sensor logs

outlet logs

so i guess i had to wait for the command every 30 minutes in the instructions it says that it will detect humidity and temperature every five minutes but it's not doing that and also I don't know what they mean by cloud I thought this was a zigbee device not a Wi-fi

You can try this custom driver : [RELEASE] Tuya Temperature Humidity Illuminance LCD Display with a Clock - #2 by kkossev

First, manually change the device driver.
Then, configure the maximum reporting period to 5 minutes, temperature and humidity sensitivity and click on 'Save'.
Finally, pair the sensor to HE again. The pre-configured parameters will be sent to the device during the pairing process.

You can experiment with temperature sensitivity less than 0.6 degrees and humidity sensitivity less than 6% ( these are the recommended settings from the manufacturer), but watch out whether the device will not start to send updates too frequently... if this happens, set the sensitivity parameters as recommended in the leaflet.

hey thanks for the reply I appreciate it i'm still have issues with the sensor it's only report at 30 minutes I dont understand why it's doing that in the instructions indicates that it will detect temperature and humidity every five minutes


What are your Temperature and Humidity reporting periods settings?
Did you pair the sensor again to HE, after saving the preferences?

so in the past week I have purchased 2 rebranded cheap chinese zigbee devices from amazon and both of them did not work as expected It was basically false advertisement Today I received A new zigbee item from amazon not no rebranded cheap knock offs from China so far everything seems like it's working as is suppose to





Undoubtedly, Aqara/Xiaomi devices are of a much better quality if compared to most of the Tuya branded devices!

Note, that the temperature and humidity reporting intervals for this device are not configurable, but the hardcoded Aqara values seem to be better than the previous Tuya device defaults.

You may keep an eye on this sensor presence state, these old generation Xiaomi/Aqara devices are known to fall off the ZIgbee network sometimes.

1 Like

hey I came across the issue you mentioned about the device being disconnected from the Zigbee Network is there a way to fix this issue and avoid it Instead of the workaround which is pairing it again to hub If not can you recommend me a Thermometer that is not bad

thanks

Hopefully, some HE forum members from the US can chime in and recommend a Zigbee temperature and humidity sensor. Most of the devices that are available in the US and EU markets are different.

1 Like

These work well with built-in drivers

1 Like

I like the Sonoff SNZB02. They're well priced and stable on the network. They all read about the same temp/humidity too high or low, but that's easily fixed using the driver offset. Batteries are cheap too.

2 Likes

@noname10133
I agree with @coreystup , here is a screenshot of my SNZB-02 configured to report every 5 minutes :

1 Like

Download the Hubitat app