Z-wave switch - force excluded and can't include again

  • I force-excluded a GE in-wall Z-wave dimmer switch. My Hubitat hub now refuses to see the switch when I try again to include it.

  • Is there a database in the hub that has blacklisted the switch, and if so, how do I correct it?

I've tried resetting the switch to factory settings. I've numerous times followed the protocol for excluding and including the switch.

I've successfully added eight other switches and other devices. Love the hub, I think, once I get past this issue.

Thanks in advance for any help.

Can you open another browser tab and open the live log? Then when you do an exclude, you should see in the log if the exclude is actually running and successfully excludes the device. To me, it doesn't sound like the exclude is being done 100%. Hope this helps at least a little bit!

Thanks, but yes, I see the exclude(s) in the log and there doesn't seem any error message. These are the last two times I tried yesterday:

Well, that is good news then..definitely seems like it is excluding it properly.

Other thought, how far away from the hub is the switch? Wondering if you need to get it closer for pairing.

I put the hub right next to the switch - long extension and ethernet cables just for that purpose. Thanks.

Definitely sounds like you are covering all bases then. Sorry I don't have any other ideas for you!

Issue resolved and switch now included on my Hubitat.

I think flipping the breaker for the circuit somehow reset the switch hardware in a way that the factory reset procedure wasn't.

The device had not been paired with my VeraPlus. I tried pairing/including it with the VeraPlus with no luck. So I then flipped the circuit breaker, and was then able to pair it with the VeraPlus. I then unpaired/excluded it from the VeraPlus, and was able to then include it again on the Hubitat.

Thanks, chevyman142000. Your hints helped convince me I wasn't missing anything obvious with the Zwave switch, and that I had to get more creative.

Now, to figure out why a Zigbee plug-in dimmer won't initialize with the Hubitat. Hmmm....

1 Like

Awesome! Glad you got it figured out. For future, you could try pulling the little air gap thing on the switch itself which also might help.

Yeah, had pulled the little air gap thingie several times, which I'd learned from this Iris video. It didn't seem to help. Maybe something was still stuck until I completely powered down the switch through the circuit breaker.

Anyway, all's well that...

Thanks again!

1 Like

Quoting the ever popular @JDRoberts:

That said, with GE switches specifically, the airgap isn’t always enough to fully reboot the switch. So with this brand specifically, if you’re having trouble getting it to respond when it used to work just fine, trying turning off the current at the circuit breaker and then restoring it. That’s often enough to solve the last connection problem.

1 Like

Ah, yes. Might've saved myself time if I'd found the earlier comment from @JDRoberts, but it reinforces my impression on what worked.


1 Like