Z-wave Schlage Connect exclusion failing, is it a distance to hub issue?

Just bought a new Hubitat Elevation. I'm excited to start my smart home journey. I spent about four hours this morning trying to exclude the lock (because instructions said you exclude first and then include).

It is failing to include every time. How far does the hub need to be from the device? I'd say it's about four feet but there's also a wall between the two.

Did you mean to say "exclude" here? I ask because at least one other user has reported that the Exclude action result isn't being shown on the Exclude page itself (as it should be).

But the exclude action should still be showing up in the Logs though... If you go your past logs for that timeframe, do you see anything there about exclude?

And welcome to the community!

Sorry yes, I mean exclude.

1 Like

I'll have to look where the logs are located. Am I supposed to see an event, and then know it's excluded anyway? And then connect the lock with the include command?

It's a good practice to do any include/exclude events (among other things, like OTA firmware updates) within close proximity to the hub. A good number of people have built test rigs that can house and power a device for 'service' close to the hub, then install it in its permanent place. I've learned my lesson numerous times (or not, as the evidence shows) that 'close enough' is closer than you think when there are walls and massive metal objects between the device and the hub. Even something as simple as an appliance cord with pigtails can power a mains-powered device while you operate close to the hub. (Of course, a battery device doesn't have that issue.)

If your battery device must be installed before inclusion, look at getting a long power cord to move your hub around (and a long patch cable, if you use wired networking.) It's to be avoided if you can, but sometimes you just can't.

To your specific issue, exclusion before inclusion isn't a requirement. Yes, it helps lessen issues, but it's not strictly necessary. I would simply try to include it close to the hub, then go from there. You can also try a factory reset on the device, which sometimes deletes all hub pairing info.

I don't have an example to show, but when you do a successful exclude, you should see a confirmation message in the area where I have a red box here -- it'll say something like "Unknown z-wave device excluded"

Just double-check, are you first initiating the Exclude on the page shown here and then do the exclude action on the device itself (which varies by device of course)?

I know I've brain-farted in the past and forgot to do the proper button sequence (or whatever) on the device when I was trying to exclude it.

But yeah, overall, you are on the right track with doing the exclude first -- that's ALWAYS a great idea to help ensure you're not going to create a ghost when next including.

Yes, I did this. I even did a factory reset beforehand.

So even if the lock says the exclude didn't work, the log might? I'll try again later today. I do recall the page said something in the red box area but I can't recall right now. Thank you for your help!

1 Like

For the other user who isn't seeing the exclusion confirmation in the UI, his logs did indeed contain the correct/expected messaging about the successful exclusion, so checking the logs should give the real story.

JB_TX has good advice about perhaps moving the lock & hub closer for the whole initial-pairing process - many folks need to do that with locks in particular. I've never had to do it myself, but it's not uncommon.

My husband had a very long ethernet cable and we put the hub right next to the lock. The exclusion worked almost right away. Then I tried to include, and the lock said it didn't work. But then in settings I see a z-wave radio device:


There used to be a discover button but I pressed it to see what it would do, and it didn't do anything.

You need to remove that... It's a ghost.

When you factory reset the lock, you really don't need to exclude. Remove that ghost you created or you will wreak havoc on your mesh.

Now with the schlage locks you need to pair them within 2 or 3 feet of eachother because of the whisper key exchange they do during pairing. After that you can move things to their final resting place. You would also want a beaming repeater as close to the lock as you can.

Now that said, you should be pairing your mains based devices first (electrically powered) and battery based devices second. Read this post and pay attention to the z-wave section. Especially the section on building a strong z-wave mesh. The overall post though will help you avoid some gotchas! Get rid of that ghost!

OK I removed the ghost.

I factory reset the device.

Then i skipped exclusion and tried inclusion. The lock almost immediately said the process didn't work.

Here are screenshots from the app, including logs. Maybe that will help diagnose this issue?

Oh, and the hub was 1 foot away from the lock at the time.

Others are better with these mysteries than me, but I have always found that power-cycling the hub fixes the 'Z-Wave network busy' messages. (And by power-cycling, I mean doing a proper shutdown from the menu, removing power for a time to let the Z-Wave radio fully shutdown (I set a timer for 5 minutes. I know it's actually a shorter period, but I never can remember the actual time.), then re-apply power and let the hub boot up.

BUT... Make absolutely sure you don't have any remaining ghosts, though. Fix those ghosts, first.

I don't think a lot of people talk about this, but I get these messages without any ghosts when an inclusion/exclusion/replace/repair/etc. goes wrong. They don't automatically mean you have ghosts, but -again- you have to make sure you don't have any ghosts. I have found they will hang around until you fully reboot the radio.


Can you post your z-wave details page from a pc and paste it here?

Also what version and model is your Schlage? Look at the label in back of the lock to confirm the firmware. If it's an older lock with anything less than the 7.10 firmware it won't connect to anything above the c5. This is because of the lock's firmware and the fact that schlage has no interest fixing them.


There is no label on the back of the lock. We bought it at Lowes in late 2019, if that helps.

Here is the details page image:

You have to pull the knob side off the door. It'll be next to your original codes. That said, what model lock is it?


It's the Schlage Connect. I appreciate your extraordinary patience. Will report back.

There are a few models with that name: BE469, BE469NX, BE469WK, and BE469ZP. Of these, only the BE469ZP is guaranteed to have a recent firmware version that will work with no issues. It is also Z-Wave Plus, while the others are not.

1 Like

BE469ZP according to the box. I have not had the chance to check the actual device yet,

1 Like