Z-Wave reliability

Hello community, I've tried searching with no luck but I'm having reliability problems with my z-wave devices. I'm curious on what troubleshooting and diagnostic tools there are to see why some device stop responding.

Some background, I've updated to the latest versions and have chosen to go with the Zooz brand. Everything I have is Z-wave. All of my automations will be ticking along then one device will stop reliably responding to the hub. Its not always the same device nor type of device. It seems as though something that gets manipulated often has a less likely chance of having the problem happen to it. A question I see lots is about the quality of the mesh network but a device that frequently stops working is only a few feet from the hub plus I bought multiple plugs and switches and installed them to try to improve the network. I've tried multiple soft resets and each time it will get everything to work again but then slowly the network gets worse. Also I can cycle power on a affected node and it will return again for a limited time.

A couple questions I have, is this to be expected? Is Z-wave just like this? Is it perhaps my brand of devices? I can't find anything in the z-wave logs that points me in a direction, what should I look for in them?

Thanks to everyone for your help

So let's start with this is not normal, but I have seen and heard of this when a ghost is present or a device is starting to have issues. Let's start with can you post a copy of the Zwave Details page?


This is the page that Bear is referring to - Settings>Z-Wave Details.


Whew. A big topic with lots and lots of angles. It doesn't sound like your experience is normal, though zwave does require more care and feeding than some folks are used to. That aside, many zwave mesh problems are the results of ghost devices. Can you post a copy of your zwave details page? I'm not sure a soft reset is all that helpful in this case.

Look out for is Zooz 4-1 sensors, the older model. If you have any of those IMHO just rip them out now and throw them away.

1 Like

I always thought he was the army of "be"


Everybody says this is not normal but its been my exact experience as well. All my wall switches and dimmers are Inovelli and my wall plugs are all zigbee. I have never once had a zigbee device not respond, not once! But the z-wave stuff is another story. I constantly have 1 out of a group scene not respond. I'd say at least every few days this happens. The only way to minimize really is to not have a lot of devices firing off at the same time. If I could back in time, I would have looked for zigbee switches. Even the few wifi switches I still have are flawless. Z-wave, IMO, just sucks.

Knock on wood, but both my Zigbee and Zwave meshes have been solid for some time now.


There is another thread that is talking about some ZW devices going unresponsive after a reboot/fw update but then come back after first manual use (or event trigger). I think I might be experiencing this but there are many other factors to consider in my setup so can't be sure.

I have mostly Zooz for lighting + Jasco for fans and they both work great. Some of the older Jasco/GEs had issues I think but the new stuff is okay. I use Zooz for my clients due to the relatively low cost, the type of switch available (toggles vs paddles) and so far the reliability. :crossed_fingers:

Sorry for the noob question but it keeps telling me I can't put median in the post. How can I upload a snip?

When my devices stop responding neither a force from the hub or a rule trigger will work.

You might have to wait for a bit to be allowed to do this. Your account is still relatively new.

Do they start working if you physically switch them on/off or in the case of the dimmer turn the power off/on via the bottom tab switch thing?

1 Like

Maybe @bobbyD can flip a switch to enable uploads since you're in need of help. New accounts are not intially enabled to upload to keep spammers from dropping in and leaving a bunch of poo in the forums...


You should be able to do it now. There is a short period that the system requires for new users to browse the community before they can upload media, to avoid spammers. I manually updated your account.

1 Like

Z-Wave will be there when your router succumbs or when your neighbor brings home a super powerful new shiny router that blows your Zigbee devices out of your network. Does it have disadvantages, sure, you found one.


@biwaskow Ok you have at least 3 ghosts that need removed (the lines with no routing) This is likely the reason your mesh is bad. These are caused by failed pairings. If you know which devices had failed pairings, disable power to them (air gap them works too) and remove the ghosts. When done run a z-wave repair and wait a day for things to settle down. If they are legit devices, delete them, reset the device and repair as they don't have routes.


So I'm seeing 3 devices without routes (0x0A, 0x0F, and 0x10) that don't look like they've had measurable communications.


131 route changes for node 0x13? that seems excessive


An S0 sensor that goes through S2 repeater. That is bound to cause problems.


These three are at least a big part of your problem:


  1. Remove power/batteries from the devices
  2. Hit "Refresh on the Z-Wave Details for each device until the "Remove" button appears (may take multiple tries)
  3. Hit the Remove button (may take multiple tries) to remove the device from your system
  4. Pair the devices again

I also usually reboot my hub after removing devices, as that has seemed to help w/pairing devices after doing a removal. YMMV.

1 Like

And is that "Zooz 4 in 1" one of the "bad actors" that we've seen causing problems before? I believe there have been issues w/some of their multi-sensors spamming/killing the mesh.

1 Like