Z wave problems

Well once again did not follow your instructions.. (sorry)... it's night at here and I managed to take mini usb off but did not wait 30 seconds and did no remove power from the wall. Family is going to be pissed if I wake them up. :slight_smile:
Going to do that tomorrow though I now managed to get rid off other sensor by clicking refresh and after that remove. Other one seems to be pain but maybe tomorrow it will work when I follow your instructions.


After night managed to remove that last problematic sensor. Everything seems to be ok now. Added new sensor to hubitat and it went as smooth as always. I do not understand what happened yesterday. Is there any known reason what causes pairing to fail but devices still can be seen in z wave list?
It also seems like those two devices got whole z wave environment go crazy. Actually I did not notice any device that was not working at the time but for example z wave repair was failing with every node (timeout).

1 Like

A few actually.. Most related to S2 security failing to bootstrap properly. 2.2.6 ignores all S2 failures on inclusion and moves on to discovery anyway..

1 Like

Ok, thanks for the information and support. Let's hope that it was just a rare incident.

1 Like

If you are referring to the S2 security bootstrapping failure.. That is completely handled by the SDK and not exposed to the hub software.. We are looking at updating the SDK and radio firmware for future hub releases though..


Yes! Let’s get all the latest bugs.

1 Like


I'm having exactly same issue that I had before but it seems that fix doesn't work anymore.
This device:

Does not exist. I can't remove it. Tried refresh, waited few seconds and pressed remove -> no go.

Log says:

Without refresh, just with remove I get:

Is there anything that I can test to get rid of that particular ghost device?


I have now tried to revert older backup. That does not help either.

The 0 SDK failure node is no longer in failed node list says that the hub got a response back from the device so it removed it from the eligible list for removal (per the SiL SDK requirements). You'll have to power down the device (or remove it's ability to send a response) before you'll be able to execute the remove successfully.

yep, but device is not there..it's a ghost. There can't be no answer from device because that particular device is not plugged anymore.
Of course I tested different possibilities like reverting to old backup, excluding device, booting hub and tadaa.. and result is that ghost line is still there but device is gone.
If I pair device again it is then completely new device instance and has nothing to do with that ghost line. Device works fully and I just have additional line in z wave list which makes me want to throw my hub out of the window :smiley: ..just kidding..

So I'm running out of skills.. and luck.. any ideas?

Hmmmm it seems to think something is responding. Maybe it isn't the device you think it is. May need to power down the panel and then try it.

Yep that I could test that I unplug all outlet's and try once again. I'm 99,9% sure that it is the one that I have been handling but you never know.
I'm afraid that this is database issue and it's just corrupted and there's nothing I can do with it. Hopefully support or someone can.

Okay...tested one by one. Did not help.

Reading back through this, when you hit Refresh and then Remove it looks like the proper sequence is being attempted but times out. Could keep trying this path, but it may be time to grab a Z-stick and try removing it.

What is that z-stick thing that you are talking about? Is that a way to remove ghost devices from z-wave list?

It's less and less needed as time marches on and more of the functionality is implemented within SiLabs SDK for the 700 series. But using the method above doesn't use the SDK or anything 700 series related. (Using a UZB700 with PC Controller uses the serial interface and thus is functionally identical to a UZB500.) One must believe that eventually SiLabs will get all caught up on the bugs and distribute a SDK we can live with. (Meaning the bugs that remain are too obscure to hit us daily or even monthly.)

While we wait for that golden day, using a UZB500 and PC Controller software on a PC can reduce frustration, somewhat. :smiley:


So did I got it right.. it's this what I need:


I'm not familiar w/that particular model, but it looks right. Amazon for those of us that don't read Dutch?

Looks like it's a 500 series.

Okay. So based on that information model should be: ZMEEUZB1 ?
Here's link in english:

..that wasn't by the way dutch.. :smiley: It's Finnish. One of the easiest languages to learn and speak.

Darn it! It didn't look quite like Dutch but I couldn't tell what else it might be. At least I was kind of in the general neighborhood. :slight_smile:

And yes, that should work fine, though I have no experience w/that particular model.

I understand that even little children can speak Finnish. Is that true?