Z-Wave Plus dimmer level not updating when digital commands sent

I installed two new GE/Jasco Z-Wave Plus dimmers today to take advantage of the instant updates. They are using the Generic Z-Wave Smart Dimmer driver. They update switch and level attributes correctly when I make physical changes at the switch, but when my automations send level changes, the new levels are not reflected on the device page. Please don't tell me I'm going to have to end up polling the Plus devices to get correct dimmer levels....

Physical change logs correctly...

I get absolutely no log entries (debug or descriptionText) when doing a setLevel from the device page.

Yeah, they update correctly from command changes.
So sending a set level, say 50 when the light is off does nothing?, it doesn't turn on the light and there is nothing in the logs?

The light changes correctly, but nothing is reflected in the logs and the device page never gets updated.

Ok, I have one of these, I'll pair it up in the morning and see what's up.
It did pair to the smart driver right?


I meant it initially joined to that driver correct?

Correct, this one joined this way, I did not have to update it.

The second one initially just joined as "Device", I had to go in and switch that one. But they are both behaving the same.

I was experiencing the exact same problem. I had to use the Generic Z wave dimmer driver in order to get it to update correctly. Now I am using a custom driver.


I've been having the same problem with Leviton dimmer modules (Generic ZWave Dimmer) and Linear WD500Z-1 (Generic ZWave Smart Dimmer)

Lights would function correctly by either manual (from device page) or RM automation but no response was logged nor parsed.

1 Like

So everything worked correctly with the "Generic Z-Wave Dimmer" driver?

Can you post up the fingerprint for this one?

Ok yep if I change my new Plus dimmers to "Generic Z-Wave Dimmer" they appear to be updating correctly.

1 Like

What's the fingerprint? Is that the inClusters thing?

Yes, it's at the bottom of the driver details, in the data section.



This is the one that paired correctly as Generic Z-Wave Smart Dimmer:

This is the one that initially just paired as "Device" and I had to change it:


Yup, thanks.
Ill get the driver fixed, for these devices.




So everything worked correctly with the "Generic Z-Wave Dimmer" driver?

No I have the issue with both the Generic ZWave dimmer and the Generic Smart ZWave dimmer.

What is strange is the issue is not on every dimmer. I have 6 of the same dimmer modules ** Currently only 3 have the problem.

  • Lights function from automation
  • Events show no entries
  • Active log does not have any entries from any of the 3 "problem" devices.
  • The problem devices are some close to the hub, some further away.
  • Some modules work fine and are only a few feet from a "problem" device.
  • Refresh does update the status

I have deleted the automation and reentered it. No Change
I have unpaired deleted the modules and repaired. No change

I have used the "Basic ZWave Tool" and can read the Capability Report:

dev:2672018-11-20 08:47:17.644 pm infoCommandClassReport- class:0x73, version:1
dev:2672018-11-20 08:47:17.138 pm infoCommandClassReport- class:0x77, version:1
dev:2672018-11-20 08:47:16.642 pm infoCommandClassReport- class:0x91, version:1
dev:2672018-11-20 08:47:16.137 pm infoCommandClassReport- class:0x86, version:1
dev:2672018-11-20 08:47:15.633 pm infoCommandClassReport- class:0x72, version:1
dev:2672018-11-20 08:47:15.133 pm infoCommandClassReport- class:0x85, version:1
dev:2672018-11-20 08:47:14.662 pm infoCommandClassReport- class:0x2C, version:1
dev:2672018-11-20 08:47:14.560 pm infoCommandClassReport- class:0x2B, version:1
dev:2672018-11-20 08:47:14.558 pm infoCommandClassReport- class:0x2B, version:1
dev:2672018-11-20 08:47:11.788 pm infoCommandClassReport- class:0x27, version:1
dev:2672018-11-20 08:47:11.358 pm infoCommandClassReport- class:0x26, version:1


Generic ZWave dimmer Devices

  • deviceType: 5894
  • inClusters: 0x26,0x27,0x2B,0x2C,0x85,0x72,0x86,0x91,0x77,0x73
  • outClusters: 0x82
  • deviceId: 820
  • manufacturer: 29

Generic ZWave smart dimmer Devices

  • deviceType: 17495
  • inClusters: 0x26,0x2B,0x2C,0x27,0x73,0x70,0x86,0x72
  • deviceId: 12340
  • MSR: 0000-0000-0000
  • manufacturer: Sigma Designs (Former Zensys)

the below dimmer works fine in a similar location

  • deviceType: 17495
  • inClusters: 0x26,0x2B,0x2C,0x27,0x73,0x70,0x86,0x72
  • deviceId: 12340
  • manufacturer: 335
1 Like

I have a Honeywell/jasco dimmer with the same issue

  • deviceType: 18756
  • inClusters: 0x5E,0x56,0x86,0x72,0x5A,0x85,0x59,0x73,0x26,0x27,0x70,0x2C,0x2B,0x7A
  • deviceId: 12344
  • manufacturer: 57

Yup...saw the exact same thing as you were seeing. Glad it's finally getting some attention. I only spent 4 days trying to get someone to listen to me. :slight_smile:

1 Like