Z-Wave is unresponsive zwaveCrashed error in logs and nothing working

I see many other threads with this issue but all seemed to be resolved through the back end and no user accessible fixes. Recently, I am getting Z-Wave is unresponsive zwaveCrashed erros in the logs over and over requiring a reboot of my C7 hub. Please help!

Please send me a private message, we would like to further investigate.

Will do, but this being handled through PM instead of providing a solution is why I had to create this thread to begin with.

If a solution is found, you're more than welcome to share. Sometimes the solution is a replacement hub. Crashing radio is very rare and generally can be traced to a few specific root causes, such as overwhelmed Z-Wave radio, reduced bandwidth availability due to power reporting or a hardware malfunction:


I have rebooted previously as this has been happen mostly this week. That fixes it for a bit but it seems to be reoccurring regularly now. The most recent devices I added were Aqara FP1 Presence sensors, 2 of them. Those are Zigbee though, so not sure if that could be related. Prior to that, the last device added was my Tesla, but that is web api based and not Z-Wave either. I do have several "ghost" devices that I have never be able to remove but have been present for at least a year. When this started happening, the solution seems to require an external z-wave usb stick, which I have coming in this Saturday. But I sent you a PM when you asked if we need to take discussion there. Thanks for your help getting this fixed if possible.

Thanks for the PM. Looking at your engineering logs I noticed some database issues in the not so distant past, so I would start with a Soft Reset, first. Collapsing Z-Wave might be related to the inability to remove the ghosts, but we will look at Z-Wave, once you had a chance to run the Soft Reset. See my PM.


I will do the soft reset and restore tonight and see if that helps.

While I got you, why is there no easier way to remove "ghost" devices still? Finding I have to buy additional hardware and go through a convoluted process to fix them seems odd.

The Ghost removal issues are due to the Z-Wave SDK provided by SilLabs to all Z-Wave 700 hub vendors. It (and its associated bugs/limitations) control what the HE hub can do. HE has worked steadily to improve the Z-Wave experience in areas they have some control, but in this area they're limited by what SilLabs provides.

SilLabs has provided some Z-Wave FW updates recently, and we are expecting one more at some point, so it is much better than it used to be.

Make sure you have the Z-Wave FW update. If you see this button at the top of your Z-Wave Details page the Z-Wave FW update hasn't been applied to your hub yet.

If you do see the button don't use it until you hear from Bobby.


I am having this issue where I am seeing zwaveCrashed and all zwave devices are no longer working. Nothing I am doing is working. I have a c7 hub and haven't made any real changes to it in a long time. Did a soft reset and still not working. Tried to do a firmware update and that gets stuck. Does anyone have any possible suggestions on how to fix?