Z-Wave glitch

I have a C7 hub which overnight refused to communicate with Z-Wave AC powered devices (which were defined as hubs also). Battery powered sensors would communicate sporatically.
I have tried everything I can think of. I have excluded ALL Z-Wave devices then reset the Z-Wave.
I have soft reset the C7 and did NO load of a backup.
I press the Z-Wave inclusion button and then the proper device function (three quick button push on a Zooz sensor, the LED blinks repeatedly). The Z-Wave inclusion NEVER finds any devices.
Did the Z-Wave radio on my C7 fail ?
Attached is the Z-Wave Details screen from my C7

Prior to the rather drastic step of resetting the radio, your devices were all included. Therefore, they will NOT respond to an Include.

The first step should always be an Exclude. You should see a "Unknown device excluded." andthen you can proceed with an Include.

1 Like

Yeah that's pretty much the nuclear option. But it is what it is now. Hopefully you only had a few of them. As you re-include devices always stop and check after each successful inclusion to make sure you haven't inadvertently created ghosts through a failed inclusion. It's a lot easier to fix them as they occur.

Not likely.. I wish you hadn't reset your network.. Have you tried a shut down and removing the power from the hub? .. If something is hung in the z-wave chip firmware this is sometimes the easiest fix..

1 Like

I systematically excluded ALL my z-wave devices prior to resetting the radio. They showed up on the display as excluded. I did this BEFORE resetting the radio.

Yes I have shutdown. I have removed power. I have soft reset with and without a restore.

I have attempted to include AC and battery powered devices. NO device will be included.
My SmartStart on the phone shows all my devices as "not included, pending"

An UPDATE. By Excluding a device again, I can now include it. Very odd. I guess I will go around and EXCLUDE all my Z-Wave devices again. They show as "excluded unknown device"...

Question, did you try doing the full power down unplugged for 30 seconds BEFORE you reset the radio? Usually that is the solution to your original problem with no other action needed, just a simple electrical power down of the radio and reboot.

I didn't time the power down. I will start with shutdown clean and 30 seconds of no power if it happens again.
I am taking the opportunity to write out the steps I am going through to have a log of what needs to be done if I have to NUKE again....

I'd make it a couple of mins.

That's rare that it needs to be done.

Not odd. If the device wasn't factory reset it won't pair back as it will think it's not it's parent controller. By excluding it you told the device to ignore the old controller and look for a new one.

1 Like

But I DID exclude every device and had an onscreen confirmation. Now maybe if the Z-wave radio in the hub was off in the weeds the device didn't actually get the exclude command.

We're they older non-plus devices by chance?

Nope. Plus all plus devices.

They may have an issue with network wide exclusion though.

Should never really be needed with current firmware versions, it would be extremely rare to have zwave database corruption and needing a radio reset. I have never seen it come down to that on the forums anyway except for impatient people who do it before asking questions.


I am not bothered by the work required to restore things.
I am annoyed with the original problem that plugged-in devices stopped communicating. My Z-Wave worked for 2 weeks (the hub was a Christmas present). My rules had worked fine for weeks.

Its impossible to know what happened exactly, but sometimes you will get one wonky zwave device that wreaks havoc and causes so much traffic it overloads the radio firmware until it locks up. The fix is to power it off for a minute and then boot up again. If it keeps happening then you try to narrow it down to what device it is and remove it or fix it by adjusting settings.

Same thing could happen with a Wifi router, takes a little more to overwhelm one but I have seen it happen. Same fix as well, unplug and reboot.

With the most current zwave radio firmware these issues have been greatly diminished. Double check you do not have the "Update Firmware" button available on your Zwave details page. If the button is there you have an update. These instructions are still good but the version they mention is not current anymore: C7 2.3.1 and Z-Wave Firmware 7.17.1


You don't have any zooz 4-in-1's or zooz zen-25's do you? Next time that happenes, shut down the hub from the settings menu. When the light on the hub turns red, unplug power to it (at the wall not the hub) for a few minutes and power back up.

1 Like

Nope no 4 in 1. Two Zooz -- a ZSE42 water sensor and a ZSE43 garage tilt/shock.
My setup is pretty basic. Three Aeotec door sensors on closets. Three Jasco AC switches for the closets. (This was the whole reason for the C7, and is what failed today).
A Jasco outlet to play with a Aeotcc ZW189 extender to cover the garage with Z-wave

After you get all the devices rejoined, one suggestion is to post a screenshot of your z-wave details from the settings page. The gurus here may find something that needs to be addressed.


@kanewolf This is an excellent suggestion. It is possible your original issue was caused by zwave ghosts. They are a pain but can be dealt with. They can occur as a result of a partial zwave inclusion and can cause symptoms like the ones you describe.