Z-Wave firmware on C7. ERROR: This firmware target is not upgradable

  1. My C7 won't complete the z-wave firmware update
  2. The logs in the z-wave details section are blank

When I select Firmware Update in the z-wave details page, I get the following error:


I clicked on 'View Logs', but the log page is blank. I'm sure there is an easy way to enable the logs, but I just can't locate it.

Have you tried shutting down the hub (from the menu), removing power for ~30 seconds, booting up again, and then trying the z-wave radio firmware update?

1 Like

Thanks for the quick reply. I just tried that, got the same error.

Are you able to choose the device and firmware target? If this error happens immediately when opening the app, remove the app (red button at the bottom, or on the App Status page if you can't even get that far) and then try again.

If this all happens after a "normal" experience in the app UI, it may be helpful to share what device (manufacturer and model) this is and whether you have it securely included (some users have reported problems with S2 devices and the updater app).

EDIT: Nevermind, you're doing the radio, not a device. :smiley:

I'm on the z-wave details page under settings and selecting 'Firmware Update' button on the right. I don't see where there's an option to select a device.

Does the firmware update process target specific devices and not the hub?

I think he's trying to do an update of the hub Z-Wave FW...

Yup - he typed a little faster. :wink:

Yeah, sorry, I assumed it was the other way around. :smiley:

So, other question: what is the output of http://hubitat.local/hub/zwaveVersion? (Replace hubitat.local with your hub IP address or, if you know, actual mDNS name.) Maybe it's not lying to you and there isn't a firmware update, though it shouldn't display if not. This will tell you for sure.


VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:17, firmware0Version:7, firmware0SubVersion:17, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:18]])

I think 7.18.1 should be available for the C-7. so it looks like the "Firmware Update" button is there for a reason (your output shows you are indeed older). I'm not sure why it's erroring out for you. Probably one for @bcopeland to look at.


I have this same problem on my C-7 since upgrading to, This firmware target is not upgradable. On 118 currently with error still.

VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:14, firmware0Version:7, firmware0SubVersion:14, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:18]])
1 Like

@gatewoodgreen and @beRad:

It will likely speed things along if you can PM your hub's UID to @bcopeland.

Settings>Hub Details for the UID.

1 Like

I just upgraded from my C7 to my new C8 pro following the procedure outlined here: How to Migrate to a New Hub | Hubitat Documentation

Even though it says to ensure the old hub is running the latest z-wave firmware before migration, the hardware upgrade was smooth and the new hub is running fine. The new hub doesn't indicate a need for a firmware update.

I’m getting the same error on my c7. Has there been any update to this that’s not in this thread?

I’m on

And same current version:

VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:17, firmware0Version:7, firmware0SubVersion:17, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:18]])

You are on the most current hub platform.

PM your hub model and Hub UID (Settings>Hub Details) to @bcopeland so he can look into this further.

same problem i post on another thread. on latest hub firmware on two hubs (obviously not zwave). there is definately a bug and no reply..

Same issue here. I just finally migrated to a C7 from ST one week ago after it sat in my closet since Christmas 2022. After building a perfect z wave network with 90 wired devices, no ghost devices, and perfectly clean repair reports, I seem to wake up every morning to an empty z wave device table. Following the post on here to update the z wave firmware, I stumbled upon this firmware issue.
A bit of a disappointment that even with a perfectly set up z wave network, I have to unplug my C7 every morning to restore the z wave device table -and- I can’t upgrade the z wave firmware. I’d say it’s an even trade at this point - ST sucked, but I only had to soft restart homebridge from time to time. Kinda sucks worse to have to go down to the basement every morning and unplug, wait 2 minutes and plug back in. I might be at a net loss between that 2 minutes and the amount of time I’d otherwise spend getting up to turn on/off lights throughout the day.

Hope they figure this out soon. I don’t get much time to work on this stuff, and I want to get it done and behind me. Have a lot of automation to rewrite, but want to make sure the hardware/firmware is good before I start that massive effort.

If you don't mind, PM your hub model and UID to @bcopeland on the HE staff so he can include your engineering logs in his review of this issue.

Not a fix, but a possible work-around:

I think if you downgrade the hub itself to 2.3.6 firmware it may work. I am guessing something with the update button got botched up with the new UI. On 2.3.7 that button was missing and they added it back in 2.3.8, possibly is broken.

Use this URL to download the last 2.3.6 release:
It will spin for a while just let it go.

Then use the diagnostic tool and "Restore Previous Version" button.
-- Hubitat Diagnostic Tool | Hubitat Documentation

Once Zwave FW is updated you can update back to 2.3.8


thanks but my hubs that need updating are in a remote location,, seems a little risky to start going back that far in f/w.. think i will wait for a real fix..

1 Like

This may just be a UI issue where the button is pointing to the wrong endpoint or something. So maybe just @gopher.ny needs to look at it?