Z-Wave Devices w/ Missing or Incomplete Drivers

anyway i have a device type for it.. i will look at getting the freeze working

Thank you -- I agree that freeze is the primary additional need on this device.

Gocontrol WADWAZ-1.
Has two sensors- magnetic (door/window) and external dry inputs. Driver that is commonly recommended is "GoControl Contact Sensor v1.10.2, by LaFramboise". But driver does not appear to create child device as intended, such that the two "sensors" can be treated separately, as intended.

Could someone please help me figure out how to apply the suggestions on that SmartThings thread in HE? I am having the same problem with my Remotec (status doesn't update in HE when thermostat changed locally - interestingly, I did not have this issue with ST), and it sounds like the suggested fix will resolve the issue. But I have no idea what the suggested fix actually is, as it's a bit over my head!

Here you go...load up this driver and temporarily assign it to your thermostat then click the config button. Next, select the generic z-wave thermostat driver. This will configure the correct association group and live reporting should start working for you. I hope this helps.

Import this URL:


Thank you! I enabled periodic polling in the thermostat scheduler app and that works, but I want to give this a try to see if instant status updating works. You didn't specify, but I assume I need to click configure when I change the driver back to generic z-wave thermostat? Or would doing so kill the changes made why applying the driver you liked to?

I installed the driver and followed your steps and it works great! I was worried it would only update once an hour because of this:

but it updated after just a few seconds. So what is this option for?

Why is it necessary to revert to the generic driver after configuring? What would happen if it were left on this custom driver?


First time poster using Hubitat for several months and LOVING it. Apologizing in advance for if this is not an appropriate request. I have been looking for a Z-WAVE RFID Tag Reader to tie into my Schlage Locks. I love my locks and they work great with Hubitat but the locks lack NFC capabilities and I have been trying to incorporate this using an external Z-wave or Zigbee RFID reader.

I see the ZIpato / BeNext reader already has a community driver , however looks like the product is discontinued as I am unable to find a place to purchase it. In my search for alternatives I have come across the below product and would like to know if this would have native integration with Hubitat via generic drivers , or if it would be possible to request driver development for this. I have not yet purchased the product as I am not sure if this will be supported by Hubitat but would be looking to buy a couple if this is possible.

Product : ISurpass J1825 ZWave Wall Reader

Product Page link
ISurpass J1825 Zwave wall reader

Link to buy product
ISurpass J1825 Zwave wall reader

Recent youtube video showing native integration for this product with VERA hub

I have managed to find the user manual which has information such as the supported Z-Wave command classes etc... in case it is useful and shared the link below (hosted on my google drive)
User Manual PDF

Excellent post!

I've recently moved over from SmartThings with many oddball devices, but the one that I'd love to see supported with its own driver is the Fidure A1-730 thermostat (Fidure | Smart Thermostat).

The Generic ZigBee Thermostat driver works, but not perfectly. I would be happy to contribute my time in testing any new code.

[Incidentally, here's the ST code: https://fidure.com/wp-content/uploads/2016/08/A1-730-SmartThings.txt]

Glad it worked. Just ignore all those other settings. I can't remember where exactly I got that driver from originally but I just inserted the code to set the correct associations and left the other stuff there because I knew I wouldn't need it anyway.

I had a ton of stuff like that from my SmartThings years...links to things that at some point I thought were important/useful, and later could not rememer exactly why. Multiple versions of drivers I had created installed in my IDE that were almost impossible to differentiate. One of the best parts of moving over to HE was being able to abandon all of that clutter. :slight_smile:

However, I just looked at my current "knowledge base" that I've been creating for HE and I can see that I'm recreating the same problem all over again... :wink:


Already sent you this note in another thread, but for anyone looking for this here:

Hope it helps you. Seems to be working pretty well for me thus far.

1 Like

Latest version is working great! Thank you.

Feature request: Is it possible to poll the filter hours periodically (like every 24 hours) so I can set up an alert in Hubitat when it's over a certain amount? Looks like there is a parameter (4) that can be read.

I’ll dig into it for sure. I have some commented out work for this exact feature.

1 Like

Here is a device that works real well with ST but not all features in HE. I have several of these to use as refrigerator and freezer power tracking. The device is from Nortek and is the GoControl PS15EMZ5-1. I have found these available on several markets.

Good morning, Just starting my move to HE with a new C7. I have several Zlink ZL-PD-100 plug-in lamp dimmers. They are great little devices that have S2 security. Don't see a driver for it and it come up as a Ring alarm device for some reason.

Happy to help work on a driver but I have no experiences writing or converting drivers from ST.



The Include process finds the closest match to the fingerprint detected. If the device is new to Hubitat, then it's fingerprint might be unknown. Simply change the type in the Device Info page to be Generic ZWave Outlet and see if that works.

I think it would be Generic ZWave Smart Dimmer in this case (could be wrong though). Looking at the command classes, I would expect it to work with that one.


Yes, I think you are right... thanks.

Thank you all. I changed the device type Generic Smart Dimmer and that worked. I temporarily changed it to Device to delete the 10 or so child devices that were associated with the PD-100 when it was first added. Seems good now. Cheers!