Z Stick No Longer Pairs - So Can No Longer Include Without Security

Nightmare....I'm on the latest firmware and updated the Z Wave firmware while it was in beta.

Purchased a new device today (Fibaro Outlet). These are 500 series devices, so I know I need to use my Aeotec Z Wave USB Stick and Z Wave Controller to include it without security.

Plugged in Z Stick, fired up Z Wave Controller, checked the com port, selected PC Controller in the list, select Classic Learn Mode and started inclusion on the C7.

The pairing appears to complete on the Z Wave Controller software and populates all of the devices:

However on the HE side, the inclusion times out:

So I've nothing in devices list. However in Z Wave Details it is visible:

I've excluded it again once already in Z Wave Controller, so I can clear it from the Z Wave Details page. However if it won't pair successfully anymore, I can no longer include anything. I've gone through this process with the USB stick many times and never had an issue so I can only suspect it's the Z Wave Update. Any ideas anyone? Tagging @danabw (who's guide document I use)

It takes those a while to pair since they have to get all the device details from the hub. Have you tried pressing the discover button to see if it will finish it up?

Yeah tried Discover repeated times. If I start inclusion again on the C7 it just shows 'found a z wave device initialising' but times out again. Normally takes me seconds to pair this when I use it.

It gets them all straight away as shown in the first image. The issue is on the C7 side.

You may have to put the stick into inclusion mode again (dont reset it), and then press discover. I cannot remember for sure if thats how I cleared the discover or not on other devices that got stuck pairing.

Also have you tried, after removing the failed pairing, full hub shut down and power cycle? Then try pairing again.

Just some thoughts, but may very well be some sort of issue with the new zwave firmware that nothing is going to get around.

The Z Stick How to is here: How To: Remove Z-Wave Ghosts (including using a UZB Stick) with a link to download a PDF. That PDF has some specific instructions when it comes to adding your Z Stick as well as using it to add devices without security. (See page 8 towards the bottom)

Firstly, you should use "Select Learn Mode" and then Choose "NWI" as opposed to the "classic learn mode"

Z Stick Include Details from the PDF

Secondly, also from the PDF, the stick is included for use the way it shows on your Zwave Details. So, it looks like you are fine the way you are.

Zwave Details from PDF

Lastly, I would add the step of clicking the shield in the upper right corner and unchecking all of the security boxes. It looks like you managed to include your stick with no security, but that would help to ensure it. (I had issues with mine not wanting to include with no security)

NOTE: I will add that after I used my Z Stick to pair the devices I wanted, I had to reboot my hub to get them to show up in my device listing and Z Wave details. Then, I had to click discover. I only had two that I wanted to add. I did the "inclusion, update (in PC Controller App), reboot hub, discover (In Zwave Details on HE), then rename device process" for each device individually. I did not try to add both devices together.


Just had a look. I HAD forgot to disable the various checkboxes in the security scheme. It may be that since getting my new laptop and installing Z Wave Controller, that I've not used it. However as you say it did partially include. I disabled those, excluded the controller and re included - same result.

Previously it would fully include and I would be asked to name it in the Hubitat inclusion (usually I just named it ZZZ). That's how I knew everything was ok. However in your details above, it's saying that it doesn't matter if it doesn't appear in 'Devices' so long as it appears in 'Z Wave Details' and the devices show up in the Controller app - which they do.

Perhaps I've wrongly assumed that it's not ready to use for inclusion, when in fact it is (it's not like me at all to throw my toys out of the pram at the slightest issue :thinking:)

I'll re include again and try to add my device and see what happens....

Me too.

Very frustrating. I was considering buying a new stick. Currently using a ZOOZ ZST10. It was working fine the last time I used it.

Will try again today.

Still no go.
Updated Firmware to 7.17 no prob.
Tried Select Learn Mode - NWI several times.
Hub is five feet from PC.
Tried to exclude - nothing.

Any suggestions appreciated.


No joy it doesn't work. Although all devices show in Z Wave Controller and Z Wave Controller is shown with a route in Z Wave Details, I cannot include a device. A NWI on the Z Wave Controller adds the device there, but nothing shows on Hubitat anywhere.

Whoever at SiLabs is responsible for forcing this inclusion issue wants hanging from their bollocks. We should not have to p**s about with additional hardware and software, reboots, power downs just to add a device in a manner that won't crash the mesh. It's completely twatful (another phrase to add to US English!)

Edit - this sorted it - never had to fanny around like this previously but thanks @tray_e

1 Like

I cannot get the USB stick to pair with the Hubitat.

I have excluded, included, with security, without security. The Hubitat just times out the Z-Wave pair without seeing the USB stick in the PC five feet away.

I have shut down the the hub, removed power, restarted, etc. No go.

That's what mine did - if it is in Z Wave Details page but not in Devices that's fine so long as all your devices appear in the Z Wave Controller app

No devices appear in the PC app. :neutral_face:

The stick shows up nowhere in Hubitat. :neutral_face:

All I can think of is to check the com port in the Z Wave Controller settings. I find it often loses the stick version. Click the gear wheel for Settings to open the Network Management panel. As you can see below mine is not showing a version and Ive found it sometimes doesn't work when it's like this:

Click the device to highlight it, then click detect so that it populates the version like this:

I've sometimes had to repeatedly click detect or refresh to get that to show or replug the USB stick. Once it's displayed, select it again and press ok and continue as before.

You say that the PC is just 5' away. Mine is a laptop and I take it right to the hub within 1' when including/excluding the stick.

1 Like

Thanks so much!
I will continue the struggle later tonight.

1 Like

There is a step by step walk-through of what you need to do to get it to connect I posted earlier in the thread (See post number 5). Just noting that it covers the issue of making sure the version number shows up.

You might go step by step, tediously following the process and note if/where you can't follow a specific step or get a different result than the instructions state. That way, you might have a better focus on just what went wrong and others might be able to help with added information.

Since you are dealing with a computer OS (WIndows/Mac), a software bundle SI Labs, hardware from your computer as well as the z stick itself, AND Hubitat, there are multiple points of failure that could occur. Knowing which specific step helps to isolate that for troubleshooting.

Note, the link in my post takes you to a community post with a link to a downloadable step-by-step document. Click the link in that post to open the document. I linked the whole community post though because it has a bit of discussion about usage that I found useful.

1 Like

I am going to uninstall the SiLabs app from my PC and start all the way over. Thanks!

Not sure if you guys are having issues, but today I needed the Zooz Z-stick (500 series) to clean up a couple things.

I did as always, and first did an Exclusion on the stick. Then I performed an Inclusion. It all worked fine for me, so I am not sure why others cannot pair this stick.

Mine is the 700 model. I have been using it successfully for months. I tried to use it again about a week ago and it just refused to pair. I uninstalled the Silicon app and cleaned the registry and restarted and reinstalled and followed @danabw 's instructions multiple times and it just refused to pair with my Hubitat from five feet away. I did exclusions and NWI and every combination and permutation. No go. In other news, my Shade 4 opened perfectly this morning.

Still no data on the route. :slightly_frowning_face:

My Aeotec Gen 5 is problematic. Previously it would pair and show in the devices page, when I included anything using it, the new device would also appear in the devices page and pair properly.

Now what happens is that the Z Stick pairs but doesn't appear in the Device page (just Z Wave details page) All devices are visible in the Z Wave controller app. When I include a device using Z Wave controller, it appears there but doesn't sync to Hubitat. I have to reboot Hubitat, then go into Z Wave details page and click Discover on the semi paired new device to get it to complete. Even after all of that, the new device is missing some info that means that a number of entries show as 'No Data' in the Z Wave Details app as shown below (perhaps someone can remind me how to correct that, I believe there's a driver I can use to add the missing info in - I did that once before)

Previously I could fire up Z Wave Controller, include the stick, include the new device, exclude the stick in just a couple of minutes. Now it's a complete s**t show and takes forever. I need another Z Wave outlet or two currently, but haven't bothered getting them as it's too much of a tart on to add anything now. I don't think I'll be adding to the system anymore due to these issues. God I'm miserable :rofl:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.