You think you've seen some crazy z-wave routing? How about a non-repeater being used as a router?

While looking at my z-wave network using @tony.fleisher's app, I just noticed that a battery powered leak sensor was being used as a repeater for a Leviton outlet that I never use.

The route for device 0x04 indicates a 4-hop route with one of the hops being device 0x37 (the leak sensor). Here's the details for device 0x37, indicating it is functioning as a router (or at least the hub thinks it is functioning as a router).

Turning device 0x04 on and off from the device page fixed this right away ...

I've never seen a situation where the hub thinks a non-repeating z-wave device is used as a router for another z-wave device ....

Any comments @bcopeland?


Not actually possible had to be a SDK reporting glitch.


Is it possible that some other device was 0x37 when the outlet was last used?
My experience has been that the routes are not regularly updated on completely idle devices.


Seems unlikely. That leak sensor was added in 2019 (to a C-5), and the C-5's network was migrated over to the C-7 in early 2021.

Hasn't been touched since.

1 Like

accuse the hunchback of notre dame GIF


I'm having the same issue. I have a Z-wave outlet that wasn't working correctly; I subsequently found that it was trying to route through a battery-powered motion sensor.

This is the Z-wave info for the motion sensor. The dining room floor lamp is the device that isn't working correctly--presumably because of trying to route through the non-repeater. The outlet does work if I move it near the hub.

I tried running a repair on the motion sensor, but it errors out as unreachable--odd, as it's functioning perfectly normally as a motion sensor, so it's communicating with the hub.

I also tried using a Z-stick and Z-wave PC controller to reset neighbors, but that fails too.

Unlike the OP, turning the outlet on and off didn't change anything.

Any suggestions?

I moved the motion sensor next to the hub and ran repair, which did remove it as a repeater.

Ugh, now I have another non-repeater trying to repeat. And this time, running repair hasn't fixed it.

Plus, I've got several plug-in devices that should be repeaters, which are showing up as non-repeaters!