Yeelight Integration, all working but can no longer change light level

I have a group of 5 Yeelight RGB bulbs in living room floor lamp, been working great for years.

Recently I have lost the ability to change level state ie dim / brighten, whether using dashboards, in device settings, voice commands through Google Home and its usual scheduled actions in rule machine and simple automations.

Colour changing and temperature, on off etc all work properly. Rules execute all parts minus the light level change. When light level change is requested, I get the following errors in log and level change in device info stays unchanged.

dev:72021-10-04 09:20:42.418 pm 
errororg.codehaus.groovy.runtime.InvokerInvocationException: 
groovy.lang.MissingMethodException: No signature of method: java.lang.String.call() is 
applicable for argument types: (java.math.BigDecimal, java.lang.Integer) values: [5, 1000]
Possible solutions: wait(), any(), wait(long, int), take(int), trim(), collect() (method setLevel)

Lights can be fully controlled in Yeelight app, anyone with any ideas on fix?

Been this way for a couple Hubitat updates (was hoping it would solve itself lol) All I can think is fully remove it all and re add but figured ask here before re-doing everything.

Anything but level changes work without a hitch,

dev:72021-10-04 09:22:19.340 pm infoYeelight Bulb color is Soft White
dev:72021-10-04 09:22:19.332 pm infoYeelight Bulb color temperature was set to 2700°K
dev:72021-10-04 09:22:11.626 pm infoYeelight Bulb color is White
dev:72021-10-04 09:22:11.622 pm infoYeelight Bulb color temperature was set to 4000°K
1 Like

All 8 of my Yealight RGB bulbs works fine with changing levels in rules or on device page, can you change the level from the device page for the bulb that isn't working?

Make sure you have the correct driver set:
image

1 Like

Thank-You for the reply.

No level change from device page. Driver has been "Yeelight RGBW Bulb" on all five since installed years ago.

Just swapped one bulb to "Yeelight RGB Bulb" and can change from device page now. Will swap them all and play with group, but looks like that could be the culprit...

What is different from RGB vs RGBW driver, and I wonder why it worked for so long and then stopped this summer?

Hopefully solved will post back after some testing and time to confirm.

edit: one thing I notice right away with RGB driver as I can't adjust by colour temperature from device page anymore, guess that's one key difference. I use colour temp changes in living room more than any colours, odd.

I'm not sure what the difference is myself, I have the color4 bulbs and this is the driver it's always been for me.

I get the same error when I change mine to the RGBW driver and change the color temperature or level.

@mike.maxwell
Are you able to check why we get errors on the Yeelight RGBW driver? Also what's the difference between the RGB and RGBW drivers?

Level Change Error:

Color Temp Change Error:

Just found this thread about same issue:

1 Like

Jackpot, exact same issue as myself, I will pick up asking in that thread.

As for RGB vs RGBW driver, once changed to RGB I can change level again but lose all ability to white CT modes, Says "changed to 2700k" in logs but light still red or blue etc lol

Will go back to original driver and use Yeelight app for level changes for now...

we'll have an update for this in the next hotfix

2 Likes

Download the Hubitat app