Yale Assure 2 lock with z-wave module

I was so excited to get my new Yale Assure 2 lock with the z-wave module......until I discovered that it only supports S0 security. That was not made very clear at all on the Yale website. Yale says that a US version of the module that supports S2 is available, but I cannot find one except on ebay.

Depends which module it came with. The green ones (part AYR202-ZWV-USA) only do S0. The black ones (part AYR-MOD-ZW3) support S2 and are zwave 700.

So unless the model # ended in ZW3, it only does S0.

Making it even more fun, if ordering off Amazon, a lot of times the listings don't show the actual product number - so you can't tell which one you will get before it shows up.

You can buy just the ZW3 module off eBay though. They run $50-$80 depending on who/when you get it.

All that said.... While S0 isn't great (3x the messaging and all), as few messages as a lock sends it probably isn't really that big of a deal on most meshes.


Could it become a big deal if you were operating 30 S0 modules? Thanks

Yes. 30 is a lot.

Now, if they were all devices that reported infrequently, it might be ok. But for an average mix of devices, 30 S0 devices is a heck of lot.

1 Like

Thanks. Totally new to this and have 30 Yale door locks using the S0 security. This has been quite a headache. I have yet to see one of them try to use a repeater (jasco outlet) with S2 or no security. I adopted the doors that the previous manager tried to get working on a smart things and gave up. Uff.

It looks like I will be spending another $80 to get the ZW3 module. :disappointed:

However, I found this on another forum.


1 Like

Right on! That's only 2400usd for me! :slight_smile: Let me know if you can get a hold of a zw3 module. Thanks.

Anyone having problems related to not always getting lock/unlock commands in the hub? First week it was flawless. Now sometimes I don't get these commands (using ZW2 that came with the lock). I tried to remove the batteries but I still get the issue. Lock is 2 meters away from the hub.

mine worked flawlessly for like 10 months, then stopped responding and stayed in the locked state even though you manually unlocked it. I had to remove it from HE and basically re-add it as if new device. Worked again for 4 months and just now has done it again.

I can't find the exclusion/inclusion instructions anywhere for it. Are you just factory resetting the whole lock?

Download the Hubitat app