Xiaomi Aqara Button issue

Hi, I have one that works, and 2 that dont. One is dead and arrived so. The other I am hoping I can get going.
The problem is, that it connects to the hub, but the stops behaving.

The only difference I can see is the one that works is connected as a Device, and then I changed the driver, while the one that does not connected as an aqara button.

I have tried several drivers.

Little pocket button
Aqara Button User 1686

00158D000205A2FC 2019-01-29 3:52:20 PM GMT
Little Pocket H
(Aqara Button)
Xiaomi Aqara Button User 8319

00158D000212FC65 2019-01-29 3:49:55 PM GMT

Its the Little pocket Button that works. The other shows in the logs like this and controls nothing. Occasionally not giving anything in the logs:

Ah, it has chosen this moment to stop showing anything.... do I send it back?

I'm suspecting that the button was not properly paired.

First this assumes that you have the community drivers loaded in HE.

  • Remove the Button from the drivers page.
  • Go to Discovery and do the pairing again.
  • if the device shows up as device only on the label DO NOT SAVE. Repeat pairing.
  • If The Device shows up with the correct MFT information you can save it.

thanks. I have tried that a couple of times, and yes, tried 2 different drivers from that wonderful contributor @veeceeoh

Does the info populares correctly during Discovery?
This means Associates the correct driver?
If not can you check which device modelo you have please?

Those buttons ship with their batteries already active (no tab to pull). Have you tried the battery from the working one in one of the others to see if it's just a battery issue?

When you removed the battery, was it for at least 10 seconds? Reset them by pressing and holding the paring button until the light flashes three times. Remove the battery for 10 seconds again, then put it back in and try pairing again.

Don't give up too easy. Study the threads on Xiaomi here and on ST for advice on resetting and pairing. I have had trouble with some of their devices when pairing. Some are easy, some really put up a fight. Remember, they are good if you use a compatible repeater like the IKEA Trådfri outlet and can handle the pain in getting them to pair, but they are not compliant with the Zigbee spec. Pairing often requires perseverance.

Of course, all the testing should be done with the battery you know to be good, otherwise you have not eliminated that variable.

New battery, did the double pairing, paired apparently OK, But Nada... nothing. Thank you for you help folks... buying another .

1 Like

With hub in pairing mode, until the device pairs, continue pressing the small button found on the perimeter edge of these buttons every few seconds. If there is no button on the edge but a small hole on the back, same deal, using a paper clip depress the switch in that small hole every few seconds.

You should see an led light blink several times as you press that button or switch. I've found these buttons and temp sensors pair fairly easy using this method. And if they ever drop off your mesh you can press these items the same way and they will rejoin even if the hub is not in pairing mode.

I'm using @veeceeoh's device handlers for my Xiaomi devices and have switched to Ikea Tradfri smart plugs for repeaters.

I had a contact sensor I just bought act this way. Paired, but no response. First time I encountered that. Pressed the pair button briefly after pairing (which like you, I was able to do fairly easily), and then it gave me battery level, but still no response.

Left it paired and did nothing more. Checked it the next day and it now works normally and has been working just fine even since. Might be a similar issue. One thing I did notice is that each time I briefly pressed the pair button, the last checkin value would update. If you get this, you may have a similar issue. So you might try just pairing, leaving it overnight and then see if you get normal behavior the next day.