Xfinity XHE1 to open garage

RE 5.0, Xfinity Zigbee keypad. Hoping to open/close the garage with specific codes.

Simple rule:

I'm just typing in the code and waiting for the beep, not hitting any of the arm/disarm buttons.

Whenever I type in my code, this is what the logs show:

This worked once (opened the garage). Will not close the garage, will not re-open.

I enabled logging but I'm not getting any logs for the rule.

Any ideas?

For shits and giggles, can you arm the keypad between attempts? Memory says I had to do this for an Iris keypad that I think is very similar to the one you’ve used.

That didn't work either :(.... although at least the rule logged something (upon disarming after arming)!

2021-08-05 06:48:36.198 am [info] Open Garage with Keypad: Keypad lockCode Kris

...but the garage didn't open.

Hoping to switch my airbnb over to Hubitat... as soon as RBoy's Rental Lock Automator is ported, heh.

Bumping this up... Does someone on the Hubitat team need one of these keypads to help? PM me an address and I can drop one in the mail :).

1 Like

Tagging @mike.maxwell

this doesn't sound like an issue with the keypad.

Agreed, I'm asking if the Hubitat team needs one of these for their lab to fix the Hubitat issue :slight_smile:

1 Like

what driver is being used with this keypad?

1 Like

"Centralite Keypad"

OK, can you post the event logs for the lastCodeName attribute?, it should look similar to this:

Just a bunch of "keypad disarmed by.."

I'm just using the "Keypad codes" trigger which lets me select specific people.

The Security Keypad -> Disarmed does not let me select specific codes... and it's not clear if this would only trigger if it were previously armed or not.

@mike.maxwell Not sure if this is helpful - but I noticed an issue with this tonight with an existing integration through Maker API.
From what I am seeing, the event history shows the event:

but the device doesn't seem to be saving the attribute. It shows up temporarily on the device page, but upon refresh is no longer there:

I am using the Iris V2 keypad driver. It was working before, but I'm not sure what update stopped it working.

Yes this is a bug in the capability (lastCodeName is missing), it will be fixed in release 2.2.9.


Oh this is great news! I have a lot of guests, and I cannot trigger anything from my keypad currently, regardless of using lastCodeName. I guess the system uses that internally when utilizing the trigger function for keypads. Thanks for the update.

1 Like

Hi @mike.maxwell , this doesn't seem to be fixed in 2.2.9...

the attribute was added to the schema, what gives you the indication that it's still broken?

Brand new Rules 5.1 rule not firing (also tried the previous rule, it also didn't work):

Typing in a code to the keypad only results in Keypad log messages, no log messages related to the rule.

The rule is subscribed to securityKeypad.disarmed...

When I punch my code into he keypad, the logs show that it is toggling between armed and disarmed. Neither triggers the rule, but since the rule is "keypad code entered", it should be subscribed to both armed & disarmed events I'd think...

Here are the rule settings...

Which driver are you using?

Centralite Keypad

are lastCodeName event values persisting in device current states now?