[WITHDRAWN] Unofficial Ring Integration

I am using 'Disarmed 'in conditions and it is working as expected. I didn't have to use 'off'. I did notice, as @SmartHomePrimer mentioned, that is was case sensitive.

1 Like

Weird. Maybe it was the case sensitivity and I assumed from that. I sit corrected. :wink:

Oh, correct. I didn't read enough. You are correct. If you are checking the mode attribute you check for the values Ring uses in the JSON. I could have mapped them to something like the HSM values but didn't. They are:


Sorry to muddy the water.

1 Like

No, you are both correct. I've muddied the waters.

When using the setMode action use these (they are case sensitive):

When checking the mode attribute use (also case sensitive):


One more thing to note... If you use this option...

You may not even need to check the mode attribute. That will sync HSM to whatever the Ring mode is. As a point of possible interest, the way I do this:

Obviously this could be done in one rule, with a trigger or without. I don't even know if you can create triggers anymore. Doesn't matter either way. You can do whatever you want.

Then I also have the toggle I mentioned above checked. So... I drive the HSM mode and Ring mode from Hubitat on a schedule but if I ever change it from Ring (with the keypads or app) I always sync that change back to HSM. Typically I set the Ring to Home mode before 12:15 AM but I have it on schedule just in case I forget.

I should probably change the description of that preference. It's confusing. What it's really doing is syncing HSM to Ring aka it's changing HSM to whatever the Ring mode is.


You are right. It doesn't go here not only for organization but also for visibility you will probably have to ask in another thread.

I don't have any Echo devices integrated with Hubitat currently (my Echo devices are all unplugged for now). If I had to guess the Echo Show 8 won't show up automatically as a TTS device (or device period) unless you use some type of integration written by the community. I did a quick Google and found this:

If I had to guess it would take something like this to get individual TTS devices (that's what the announcement functionality is looking for) to show up in Hubitat.

Also, as far as Amazon is concerned they would have a few hoops to jump through to see this traffic. All of the API calls we make go directly through the ring.com APIs which Amazon probably has access to but not at the Alexa support level. I'm guessing you are probably okay to leave the app alone. I doubt the Alexa support people will be rooting around in Hubitat anyway. They will troubleshoot connections with your Echos in the Amazon app but I'm guessing nothing beyond that.

First off, thank you so much for this integration. My Ring System (Motion from Camera's, Motion sensors and Ring Alarm) is a crucial part of my HA setup, so am so excited your integration let's that happen!

I am however seeing something very odd, specifically I have 3 Spotlight camera's, and only one of them is reporting motion activity back to the Hubitat.
I'm only seeing two differences between the one that does work v.s. the two that do not.


  1. The one that does report motion is of kind: "hp_cam_v1" and the other 2 that do not work are of kind: "hp_cam_v2".

  2. The "automatic" names generated by your driver show the two that do not work as "Ring Spotlight Cam Wired - NameIGaveThem" v.s. the one that does work shows up as "Ring Floodlight Cam - NameIGaveIt". So floodlight v.s. spotlight wired if I'm correct in that I didn't pick those words.

Any thoughts on if there is a potential bug I can help you with, or if perhaps I'm just doing something weird?

Thank you once again!

I may have found an issue with the Ring sync to HSM function. This appears to be a problem if 'Delay arming Armed-Away by this many seconds' is set in HSM. If you set your alarm to 'Away' using the Ring app and then set it to 'Home' via the Ring app prior to the delay expiring HSM reverts back to 'Armed Away' after the delay setting. The sync function doesn't cancel the delay. Has anyone else noticed this?

For testing I have disabled all of my rules and apps. The only thing I am running is the Ring Integration and HSM. It may be something I did but I have no idea what. I just updated to (I'm not suggesting this is the issue) , made a bunch of changes to RM rules and motion lighting before I noticed this.

If this is expected behavior please let me know.

There is not enough information for me to tell you anything here.

  • Are you polling for motion or using IFTTT?
  • Are your spotlight cameras wired, battery or solar? Are they all the same model?

If they are the same model I'm going to have to see this to believe it. Ring thinks my Floodlight cam's "kind" is "hp_cam_v1" and my wired Spotlight Cam is "hp_cam_v2". If you are saying you have three spotlight cameras of the same model but Ring thinks they are different kinds then they would show up as different kinds in the Ring app.

So, let's start off by you telling me more information. Answer the first two questions above and additionally turn on all of the logging in the unofficial connect app, open the hubitat log, and then follow the discover devices link again. Then I want you to paste me all of the logs that look like this:

"found a stickup_cam_lunar"

Leave off your location ID. I just want this part. In the log entry immediately above (above in the log means later since the log grows from the top) "found a [device kind]" you should see a whole bunch of detailed information including the name you gave the device under description as well as the kind. You can use that to confirm that the name and kind are what you think they are.

If you can't figure it out you can PM the logs. Don't paste them here as they'll likely have authentication information and hardware IDs in them.

I can maybe fix this if Hubitat provides a way for me to tell programmatically if a countdown to arm is happening. I don't do anything except blindly set the HSM mode. If there is a countdown they are not queuing the second call to set the mode apparently. Have you checked the logs with all the debugging on to see if there is any message about the second HSM mode set failing?

I will put this on the list of things to look at. In the meantime, I would suggest either not using the delay or being careful not to set the mode rapidly.

I have not checked the logs with debugging. I'm not in a position to do that now, I can do it tomorrow. I only noticed because I accidentally hit Away when I meant Home. When I switched back to Home a minute later Ring started counting down because HSM pushed it's status again. I have some rules to sync back to ring. Not a bid deal. I just wasn't expecting that and thought it was an issue with one of the alarm rules I was playing with.

Yeah, sorry about that. I wasn't sure what information would be useful, and now I realize anything more would have been. Let me look into this, I'm a bit of an HE noob, so I might have done something stupid like confused the names myself or copied the wrong IFTTT IDs. I'll take a look, thanks for the quick response.

Is the All-new Ring Stick Up Cam Battery HD supported? When I click Discover Devices it can't find it. My other devices get discovered.

Probably not. Turn on trace and debug logging in the app and hit the discover devices link again. From there it will go through all the devices it finds and put them in the log. Look for your device by name aka ctrl + f if you are in windows and search for the name you gave it. It will show up in a trace block that starts with "node: [a bunch of JSON]". Tell me the kind attribute and I can easily add it. You can also add it by modifying the groovy map on line 696 - 718 by adding a new entry for the new device. Assuming it works and uses the same API as all of the rest of the devices that should be enough. Probably will be a "Ring Generic Camera" device if I had to guess without looking at its functionality.

Also, remember to turn off trace and debug logging. It's too chatty to leave on.


Here is the line I added and now it is able to be discovered.
"cocoa_camera": [name: "Ring Stick Up Cam Battery", driver: "Ring Generic Camera with Siren", dingable: true],

Thanks. I really appreciate this app.

Did you check the siren functionality already? If so, I'll add that camera to the app as a camera with siren.

I just checked the siren and it works. I did this through the device by clicking on Siren.

What command would I send from a rule to turn on the siren? I tried actuator with "on" and "siren" as strings but neither works.

1 Like

Never mind. I figured it out. It's under 'Sounds', 'Control Siren'. I was assuming it would have to be a custom command. The siren worked via a rule with RM.

1 Like

Just installed my ring alarm today and setup this integration today. Both were painless. Great job @codahq

1 Like