Wifi Drivers are not installing for hours

Hey guys,
recently I've bought a second hubitat and 2 OTG power cables. Yesterday they've arrived and I've tried to set them up. For starters, one of the OTG cables doesn't want to power on the hub. I've tried with different combinations of power cables and power sources, but to no avail. I've left it aside and went to the second hub with the second cable. There I've had more success and it actually powered on, although the usb is on the hub is a bit "broken" as noted in a previous topic.

So far so good, at least the old hub can be connected with the nano adapter I thought. I've completed the first time setup on the new hub and decided to switch to the old one. I've clicked on install wifi drivers and the hub started saying "Working on it" for several minutes. Then we've had a power outage in the house and that was the end of it.
After the power came back on the hub was still stuck on "Working on it".
After waiting another 15-20 minutes I've rebooted the hub through the settings, again without any result. After that I've tried restoring backups, checking the network config, starting the install again, turning off the hub for extended period of time and whatever else. Nothing worked.
I've decided to try the installation on the second hub, but it also didn't work and got stuck on "Working on it", regardless of the fact that there was no power failure this time.

I've checked the logs and the only thing I see is this:

Happening on both hubs. From the network check I've seen that the speedtest doesn't work because I cannot resolve the DNS. Can you suggest anything I can do to fix them? Latest firmware.

I would do a soft reset (yourhubip:8081>>soft reset) then try again. If the wifi dongle is approved it should be picked up pretty quickly.

1 Like

So before I do the reset, I plug in the usb stick and then do reset -> install drivers?

I'd leave it out and plugged into lan. Do the reset restore then do the dongle.

So resetting without the dongle and inserting it before installing the drivers?


We're just making sure your database is clean which is what the soft reset/restore does

I will try it in a bit and update with the results.

1 Like

Should I download a backup and restore it after the reset? I don't know what does the soft reset remove, but if it removes app and drivers, I will have setup to do for days.

Doing a download is always a good idea. You can use that one to restore after the reset... When you download it it will be clean..

1 Like

Unfortunately after soft reset -> restore backup -> plug in usb -> install wifi drivers, I still get this:

PS: The backup was intentionally 2-3 days old.
PS2: I just did the wifi setup for SSID and password to see if it helps, but it doesn't seem to change anything.

Can you get into the wifi config?

You mean the router settings?

Ok, now that you've done that, shut down the hub from the settings menu, unplug power (from wall not hub) unplug hard line, power back up and see if it shows on the network. With DHCP it will have a different IP.

Edit: It doesn't swap to WIFI/Lan automatically.

@gopher.ny any suggestions?

I don't see it at the moment. I have 2 IPs that are not familiar, but neither loads any frontend. Cannot find it in the findmyhub as well.

If you pull the dongle, does one of the ip's go away?

Unfortunately no.

Ok perhaps @bobbyD or @gopher.ny has some better insight

Can you PM me your hub's id?
WiFi bit downloads and installs drivers. It's completely separate from backups. Powering off/on could conceivably help if, say, a file is locked, but it doesn't seem to be the case here. Need to take a look at the engineering logs to make the next guess.