WebCore Stop Working

Sometime in the last few months, my webcore stopped working. I have latest version of Hubitat and rebooted a few times. I also logged out of dashboard but says issues and no data showing up. All pistons are not there and none of them run.

Has this stopped working, still supported?

Working ok for me.
What version are you running?
Are you updating via HPM?

Still working for me. Saw that message while back and exited normally and went back in...

WebCoRE still works;
What usually works for me is going into WebCoRE app settings > Security > Reset Access token (note the warning if you use external URL's). Register a browser & log in again.

I have reset the token and registered a new browser a few times, no change.
Tried new browser and still no change, dashboard shows nothing.

Here is my version info:
image
image

This is what I have in the webCoRE app.

static String HEversion(){ return "v0.3.110.20201015_HE" }

How are you updating webCoRE?

I have not updated webCore since original install last year. How do you upgrade? I tried to add new groovy files but not sure how to link to new version. Unable to delete old files as webCore app is still using it. Do you have steps to upgrade?

So what version are you running. Does it say the same as mine?
Do you have Hubitat Package Manager installed?
This is how I update mine.
I will try and find the github site.

EDIT: Read post one of this thread.

I tried to install package Manger but that does not work. Keeps saying auth issue but tried my local id/passowrd and the hub account password.

I removed webcore complete and rebooted. Removed user app code as well. Re-added code and app with latest version. It seems to work, I can see dashboard, I can see my system and locations, but none on my pistons are there and when I try to create a new one, it fails

image

Did you oAuth the main webCoRE app when you installed it.
Go to Apps Code. Scroll down to webCoRE. Click on it and at the top enable oAuth.

I hope you did a WebCore piston backup before starting all this!
I had this message once while migrating but it was due to using the wrong credentials, my ST account auto-filled by mistake.

I ended up removing the app and got it working. A fresh install. Bad news, I lost all my existing pistons.. AHHHH. Anyway to get them back? I had autobackup on but not sure where they are. When I logged on to dashboard, they are not there.

Do you have any old backups of your HE configuration from months ago when it still worked? If so you should be able to backup your current configuration; temporarily restore an old HE backup with working WC, go to the cloud dashboard and jot down the backup codes for your pistons. Then restore the working config and using the cloud dashboard restore them all again. A few weeks ago I went through this painful excercise for 90+ pistons but got them back again..

Great idea, let me try this weekend.

Download the Hubitat app