webCoRE for Hubitat Updates

Sorry to go of subject, but do the pistons normally run OK and the hub speed is still good with no lockups/issues.
Just wondering.

Hub speeds are fantastic. All pistons run normally, very snappy, no lags. Its just this interface problem.

I have deleted 5 devices that are not being used. Saved all the way out.
Same problem, same error.

I also deleted my two largest pistons and still get the same error as posted before.

I also tried Cleanup and rebuild data cache.

I also switched over to the dashboard.webcore.co interface and still have the same problem.

I posted an update to further reduce upload sizes.

Logs are more detailed into what is happening. Above instructions are accurate for loading a small piston first. If you have really large device lists, the logs will show if you need to load the small piston twice to allow all the uploads on new login or groovy code update to complete.

Thx @an39511 for testing out the fix.


The performance increase is quite noticeable. Much snapper in lighting control.
One test I use to measure how well webCoRE performs is using one piston to rapidly call another piston passing variables. Before this release I could call at a rate of no faster than 300 ms before it started losing data. On the latest release v0.3.10e I can now pass data reliably at 100 ms. BTW, the same test done on SmartThings the best I could do was 550 ms.
webCoRE on Hubitat is blazing!

1 Like

Took a chance and updated and I have to say, the new version is a lot snappier. One thing to note though, if your existing pistons have IFTTT events in them, you have to go in to the edit screen and hit save in order to get the piston to subscribe to the IFTTT event. Before that, WebCoRE would respond to the get request that it was received correctly but the piston would not fire. Went in, save and all the subscriptions were reset correctly. Well done!!!

Hi guys, I'm new to Hubitat. Coming from SmartThings (webcore). I notticed that several pistons I created to be able to change the HSM status stopped doing it and I ended up with errors telling me that, for instance, the 'disarm' mode was invalid or something. Has anybody tried to set the HSM status with a button to double check? it was working before I updated both webcore and the firmware itself.

Sorry for double posting. Specifically the commands to set the HSM status are not working for me and the log clearly shows it's not taking it.

With mine I set the Location Mode, and let HE HSM control whether its armed or not. That way I can add delays and methods for cancelling etc.

I just find it easier. Any reason you cant do the same?

Finally applied the webCoRE updates.. performance improvement is massive. Very much appreciated!

Currently I live with my wife and kid. Only her smartphone and mine are enabled as presence sensors and used with a geofence. Smarthings Arrival sensors are available on each keychain but are just used by a piston to remind anybody that has left the keys at home (notification) or to beep as soon as the system detects the presence to be aware of the HSM status without checking the smartphone screen at all. Location modes (Away, Day, Evening, Night) are managed with a watchdog piston based on the geofencing and current time.

I say this to explain what I wanted to do with HSM:

-Arm away when everybody leaves. I do it by using the smarthphones of everybody at home (multi-geofence). For now, there are just two smartphones.

-Disarm temporarily as soon as anybody arrives (5 to 20 mins timeout). Only happens with the first person to arrive (still working on the details, but now this is how it is).

-When any of us are at home, movement is tracked on the living room and dining room. If there's no movement at all for at least XX mins, it arms the HSM in home or night mode depending on the current location mode.

-As soon as anybody goes through these areas, the HSM is disarmed. All of this to keep the access to the apartment in check if nobody is near the door, while avoiding any false alarm when trying to exit the apartment.

Does it make any sense?

Now, I'm forced to do it with Rule machine because the HSM can't be armed/disarmed at all from WebCore.

I think you can achieve what you’d like with the way I’m doing it.

I do pretty much the same with mine and my wife’s. Then I also have an RFID box for the cleaner and mother in law, and tags. They run off other pistons.

The way I use webCoRE is to set the location mode to away (which then arms the HSM) or home (which then disarms) and the same for night. If you use the modes in webCoRE , then configure HSM directly in HE it will trigger the appropriate HSM settings by the modes the pistons trigger, as per my screenshot above.

If you like I can PM you my piston code as an example?

Sure, thanks a lot! I think I can use your idea. Since I'm on a rented apartment, I doubt I could install an RFID, but since I have an August smart lock, I can think of a workaround. Btw, the issue that I'm having right now is that the pistons for some reason are not able to set the HSM status at all. I can "read" the current status for the HSM but can't use any command like Arm or Disarm. I'm still wondering if it's an actual bug or if it's due to the recent updates we've been receiving. I don't know.

Here's an snapshot of the most basic manual piston of all, and it fails.

I have posted an update that should fix the HSM issues. Please update.


There was a recent update to match webCoRE server version numbers, if you updated recently, please update again.

Also note that the import URLs are filled in for the webCoRE apps to make groovy updates easier.

FYI, unless something changed recently, the importURL attribute only applies to drivers. For apps, Hubitat saves the last URL you typed or pasted in to the import field in the admin UI yourself--so that's definitely what I'd recommend doing (rather than copying and pasting the app code itself) to make it easier. (Now if only there was a way to mass import multiple at a time...)

1 Like

That would be such a great option.. especially as some apps have maybe a dozen + associated child apps / device drivers. It’s not user friendly currently.

Just wanted to report that with the new release of Hubitat 2.1.4 you can pass variables back and forth between RM and webCoRE. Variables are setup in RM by creating a Global Variable and assigning it a connector. This will create a new device on the hub called "Rule Machine Connectors" and in that device there will be a child device containing the name of the Global Variable you created in RM.

This is a great way to be able to run the two rules engines and give them a way to communicate. Plus you can change these variables through the Hubitat dashboard. Very cool!


Updated release to improve device optimizations - please update.