webCoRE for Hubitat Updates

Who-hoo! There's an update in HPM for webCoRE with the following notes: "Latest release for Hubitat to run webCoRE pistons locally on HE - bug fixes, fix stays statements"

1 Like

As mentioned, pushed new release out.

Note 1 has been updated with the release.

It is fixes and optimizations.

1 Like

Any chance the update broke the feature where pistons run based off a global variable changing?

I updated yesterday evening, and noticed this twice already. Might also be due to the fact that I had some power flickering yesterday, as we had a bad storm.

To explain my system as simply as possible: I have a piston which checks a weather API and updates a global variable with a value of 1-5 (integer) based on outside brightness. Once it gets to a 2 or 3 certain lights begin turning on. The piston runs every 10 minutes as that is the refresh of the device API. I just checked that piston and the global variable was set to a 1 (one being dark, 5 being bright). It seems to be working just fine though.

I have 4 pistons that I can think of currently that all run when that global variable changes. None of them had run since this morning. Hitting test caused them to run and function properly for the time being.

I don't think the power outage had any effect on this, as even if the device was on / off and Hubitat thought it was different, the piston still should have ran. I say this because some lights turn on when the power is restored to them, and if they were off, then Hubitat thinks they are still off.

Hubitat, as well as the rest of my network is on UPS devices, and the power wasn't out for more than a second. Though it was enough to flicker the lights, and power off the TV.

Any thoughts why this might be happening? I'll keep monitoring from my end and post updates if it starts working properly. Though this is one of those cases it really only happens twice a day (sun up & down) so its lengthy to monitor.

2 Likes

My global variable changes have all been running properly (both in production and tests).

If you have details of this, send private message with logs for the piston and the global variable events.

1 Like

Hello,

I have noticed this. A day after I updated, some routines weren't firing and I did all kinds of nonsensical things to try to fix. I eventually figured out that it was my 'house awake' variable was not being represented properly and it was only THOSE pistons that contained a conditional global variable weren't firing.

I pulled my hair out for two days, tore down the code, cleared out the variable, and it still seemed to not be working correctly.

At this point I still didn't realize this could be a bug. I reverted my entire hub to 3 days prior and it was the old version of webcore and everything started working again.

After a day or two, I absolutely couldn't stand that there was an update available that I had not applied despite me somehow irrationally blaming the new version on this one tiny component having issues. In my mind it could've been a zillion other things.

I downloaded it again, I was getting messages about the WC DB not being aligned with the same version number. I'm sure its because of the way I reverted. But more importantly everything started working and all was right. WRONG!

It appeared to be working because in the time that I did all this my house awake global variable had gotten manually in sync. This was all coincidental, a day later (yesterday/today) I realized it was having trouble again. So AGAIN I just tore down my code and mary kondo'd it because I was convinced I again have done something wrong. Of course everything is working now but thats just because the global variable is in synch and it will be out of synch by tomorrow.

I still did not realize this was a bug until I accidentally saw this thread and your description fits exactly what is happening to me and its been repeatable through two installs of the new version.

I know how to provide HE logs but I don't do much log reading in WC (although it's my only rules engine). But ill get them whereever they are. You just need the logs from where the global variable is supposed to be getting changed/triggered?

I have pushed an update for the subscription error.

For pistons that have a subscription problem pause/resume or edit/save will update the subscriptions for that piston

4 Likes

I did the updates and resaved the pistons. I'll let you know how it goes tomorrow. I absolutely can't do testing on this global variable when others are asleep
The Original Series GIF by Star Trek

Thanks for posting your update. Glad to hear I am not alone.

I have updated webcore again. I won't be home much all weekend so I won't be able to monitor if that has fixed it or not, but I will post an update once I figure out if it is working or not again.

Thanks for pushing the update @nh.schottfam

I had an issue with subscription that took me a couple days to track down. My garage door was acting funny and the bedroom lamp kept turning on in the middle of the night, motion triggered by cats in my office. Not fun. Anyway, I ran a repair using HPM and that seemed to smooth things out.

Edited to add: It's very possible that I could have run the repair after the fix was pushed.

1 Like

I noticed issues too. I updated via HPM and paused/resumed the pistons having issues. So far, so good... Will continue to test.

1 Like

I monitored this today and I didn't witness any misfires. I'd like to give it one more full day of observation but so far so good.

1 Like

This looks to be working well again for me too. All lights came on when expected this evening, and many turned off just fine tonight. I also updated Hubitat to version 120 (latest) today, so I assume that may have helped as well.

Thanks for the support! Always great when there is a quick fix from the community!

Here is my shell script. I install a few files to /tmp and copy them over for static ip, etc. Have tried a few different installs. Not sure if there is a better way to install this. Some commands might not work, uncomment install git/apache as needed.

install_apache_webcore_pi_lite

I can't get the local version to render my device list. I am still running this from the cloud url until I figure it out.

It looks like you are not using the repo from note 1 in this thread. A lot of things are not likely to work correctly.

1 Like

jodie foster ok GIF

2 days, no issues. I consider the global variable problem a done deal. Thanks for your lightning quick resolution, even if it took me a week to get the symptoms to you :grinning:

I reinstalled from the latest repo, I see the style changes but still no devices on the local instance. I'm almost sure it's OAuth not setup right. Is it required to add the ClientId, Secret from the installation instructions here to the local build or hubitat config?

You do realize you are posting the setup that is in SmartThings IDE?

1 Like

Those are the instruction directly from the Wiki here:https://wiki.webcore.co/#GitHub_Installation_.28preferred_method.29 I was under the assumption that those were needed to sync with the cloud <-> local hubitat?

Just a quick couple of questions that I may have missed further up the thread.
Have you installed webCoRE on HE?
Have you oAuth'd the main app?
Sorry if these are dumb questions but thought I would start with the basics.

Summary

I'm sorry, I cross posted to this thread.

https://community.hubitat.com/t/webcore-and-hubitat/85589/6?u=c33jd13s3l

Yea I have WebCore running local but only my global params show up. I am try to debug the device list missing when I install locally and refresh the auth token in hubitat to run local instance, still not seeing devices locally but I see them on the webcore cloud dashboard.

Download the Hubitat app