webCoRE - Devices not showing as being used by an app

After the lasts HE updates, I have noticed that, if a create a new Webcore piston and select a device (Eg. "ventilador victor") and then I go to that device and it is not showing which pistons are using it. It shows that the Webcore APP uses it but dont show anymore on individual pistons which a Child APP. Why is that could be happening? It is happening on 3 HUBs I use the same thing.

Tagging @nh.schottfam

I saw this a couple of weeks ago and thought something strange was going on.
I then defined a new device, went to the main WC app and defined it to be available and saved.
Just looking today I can see that pistons are showing up in the 'in use by' area.
Can you try going into the main app and go to devices and come out again.
Does that make a difference?

What I jsut did:

1 - created a new virutal switch "teste"
2 - went to main WC App and added the device to be used
3 - created a new piston with just that device alone and save it
4 - went to the child WC App for that piston and the device wasnt there nor on the device that app was registered, only the WC main app was in there.

Hhmm. Not sure what to suggest. I'll give it a go.

EDIT: Can confirm mine is the same. Any thoughts @nh.schottfam

I have seen a couple of reports of this.

I have not been able to reproduce it. I have also had folks add debug statements to the method
updateDeviceList in the piston file that shows the update of the in use settings is being issued....

So, this one may be some underlying DB issue...but being so hard to reproduce it is hard for myself or @gopher.ny to look at it more....

I'm not 100% on this but as said above, I have seen this before.
Looking at my devices now all the pistons seem to be in the in use by section.
Maybe it takes a reboot or something for them to appear. :man_shrugging:

I may have a play later.

I rebooted and also did a soft reset on my HE and restoring the backup aftwards of course. It didnt solve the situation.

Just checking a few of my devices and I can see that some are missing pistons in the 'in use by' section of the device.
Very strange.
I have defined a virtual switch and written a piston to turn it on/off through the day.
The piston is not appearing in the in use by section but I'll monitor it to see if the piston does appear.
Very strange. :thinking:

I just added a new motion sensor to a piston I defined about a week ago.
The piston showed up straight away in the used by section of the new device.
There doesn't appear to be any logic to what is happening.

OK. Here's a bit more information.
I just created a piston for a device that has been connected for some time.
The piston appears in the used by section for the device.
I assuming this issue is only happening on new devices.
Cannot be 100% sure though.
I'm not sure if this information helps or not @nh.schottfam but thought I'd mention it.

I just did this test, and everything worked for me....

This is a head scratcher as I have seen a couple of folks with the problem, but I have been unable to reproduce it...

Here some more info for you.
If I open the piston up by clicking on it in the hubs UI, when I look at devices there is nothing there.
If I click on it and choose the device and save my way out, the piston now shows up in the in use by section.

yes, that is you editing the settings manually.

The piston sets these itself, and for some reason the sets don't seem to 'stick' sometimes.

I cannot reproduce this not sticking....

Hi @nh.schottfam
If you want me to leave this issue alone, I'm more than happy to.
Just in case you want more information here is something I tried.

I defined a virtual switch and defined a piston to turn the switch on at a certain time.
I clicked on the settings for the piston and under 'Event Subscriptions' the device did not appear. The piston was also absent in the in use by section.
I then changed the piston and put in a trigger.
Now under 'Event Subscriptions' the device has appeared. The piston also shows up in the in use by section.

Not sure if this helps or not or whether this was just coincidence but thought I would let you know.
Thanks again.

Here is the piston BTW.



EDIT: I deleted the piston and did the same again. Once again the piston did not appear under in use by.
When a trigger was defined it did appear so I'm able to reproduce this issue.

Hi, everyone. I just migrated from SmartThings to Hubitat this past weekend ... including 100 WebCoRE pistons. However, I noticed this same issue, which has complicated device replacements. I'm wondering if anyone has discovered a solution, etc. Right now, the only workaround is the direct edit of each piston's configuration to assign the devices. However, this is a difficult task to uphold over time.


I'm afraid I'm still getting this and cannot seem for find a resolution to it. Seems very hit and miss.
Very frustrating.

I know this is difficult but any more thoughts on this @nh.schottfam?
Could this have been introduced with a update that was done in recent months?

Not sure if these are red herrings, but my loose analysis and spidey sense have observed perhaps two suspects: devices with custom attributes to which the piston subscribes; and devices whose conditions are nested below other devices' coniditons.

What I have discovered is devices that are set as triggers will show up "In Use By" but if they are conditions they won't. This goes along with your observation.