webCoRE - Devices not showing as being used by an app

This problem showed up right around the time when Hub Variables were introduced back around the beginning of the year.

1 Like

If you enable full logging on the piston, there should be log statements when the piston updates the settings variable to show devices in use.

you should see during the resume a log message like:

[app:3689] 2022-05-18 06:11:22.065 pm [warn]║ updateDeviceList 1 ([266])

[app:3689]2022-05-18 06:11:22.033 pm [info]║ Subscribing to vswitch4.switch...

If folks have debugging information to help identify this, I appreciate the help

If you don't see a message like this, PM me and I'll send you some debug settings....

Sorry for the post here and not PM, but I haven't explored that yet, and this may help others. The attached screenshot shows the tail end of the piston and the "Using" and "Subscribing" statements ... clearly missing a device in the snapshot. (The device is a custom driver that overrides a Zigbee switch's "Generic Zigbee Switch" driver.)

As well, the "Office PC" device does not show this piston in the "In Use By" section.

I have screenshots that I tried to share, but I received an error that I could embed media items in the post.

Without the screenshots, this is of no help. How can I share screenshots?

If you don't see any of the lines like this: it won't help me much.

[app:3689] 2022-05-18 06:11:22.065 pm [warn]║ updateDeviceList 1 ([266])

If you account is very new, the forum may have a restriction on posting images. You should be able to drag and drop them normally

Just completed some more testing @nh.schottfam
Just defined this piston.


When I look at the three devices, The virt-lux device shows the piston in the In Use By area.
Unfortunately it does not appear for the 2 devices in the 'then' section.
When I edit/save the piston I always get this with logging on full.



With a test of the piston the logs show this, which is basically working ok.


I'm not sure if this gives any useful information.

I tested with a Sengled bulb that I assigned to a variable. First test, don't use the bulb/variable at all: compilation reveals no errors, and the device does list the piston in "In Use By". Second test, turned on the bulb via an action on the variable: no compilation errors, and the devices does not list the piston in "In Use By". Third test: trigger on the bulb changing: no compilation errors, but the piston now does appear in the device's "In Use By". Fourth test: static "is" if condition on the bulb's variable: no compilation errors, and again the device page does not show the piston in "In Use By". This matches other observations ... as if the "In Use By" logic is only considering triggered devices.

Still cannot post images, but the logs mimic those in bobbles post. No error messages. The only addition is the extra subscription line for the third test.

If you are experiencing the 'in use' problem and are in the latest beta of HE firmware, please send me a PM if you are willing to try a few tests. Victor has provided some additional debugging capability that I would like to try with someone having this problem...

Did you get the testers already or still need candidates to test the issues? Tomorrow I have time :slightly_smiling_face:

It appears that Hubitat's Release has corrected the "In use by" problem.
Perhaps others can confirm this.

Was there ever a cause for the problem discussed?

Yeah, this was one of the things specifically tested in beta.


@nh.schottfam also said it would be good to do a repair on WC installation, puase ans resume the pistons. Mine are working very fine.

1 Like

I have only noticed @gopher.ny, that I had for some of my pistons, which sends commands for more than 1 zigbee device at a time (like 2 or more switches) that I had to put a delay on the Webcore piston (+-50ms) or some of the devices were not getting the command sent by the HE hub, even though the command was sent. sometimes it worked, sometimes it didnt, but with the delay (main option on the piston settings) the problem seems to be solved. I was not having this issue before....

Yes, this resolved the issues that I was noticing. Thanks.

1 Like