Webcore can't load piston

I'm trying out webcore and wrote two pistons a couple of day's ago. Now I cannot load the webcore and the pistons (i'm using the link from hubitat 'view piston in dashboard'. It worked fine a few days ago.

(i've change computer, cleared cache)

When loading webcore, it takes forever, and after some time it say, that it could only load some parts, and that data might not been loaded correct. No pistons (i created) in sight.

Being new, is it so that webcore is something unstable that should be avoided, or am I just doing something wrong?

you might clear you browser caches / restart the browser.

You can also try an incognito window of your browser

My experience is it commonly is a browser/caching issue.

I don't know why but that method has never worked for me since WC was invented; the spinner just spins on a blank page.
I just open a tab and use WebCore | Open Dashboard and enter your credentials.
I keep that tab open permanently unless I'm adding new devices or rebooting HE.

Thanks, I’ve tried different computers/browsers/empty cache - still spinning unfortunately. If I ever get it to work I try to keep the tab open as long as possible I guess :slight_smile:

That link seems to assume that you are already logged in to the dashboard. If you use “open dashboard” first then the individual pistons should work as long as they open in the same app or browser. There should be no reason to keep a tab open once you’re signed in.

this is the message I get when opening the webcore dashboard:

you did all these steps?

Thanks for all your suggestions. yesterday I spent some time to try most, with no success (and part of day before as well).
This morning I tried logging in (on the same computer&browser as before, without any of the measures mentioned), and it works immediately. Tried on my phone as well and that worked too. Seems that the problem was not on my side, but rather some other kind of issue last two days.
Glad it seem to work (not sure how much I can trust tje sysyem though…). I’ll use it some more and see how stable/flakey it acts for me.

Totally understand you've had issues. Just wanted to throw something into the mix - I wouldn't have bought my c7 if webcore didn't exist.

no, agree it looks capable. (I've been using the C-7 for several years, but only as a protocol converter/hub (and hubitat has been very stable for that). All automations I've done in a different system (Indigo - very capable and stable, but requires a mac to run on). Thought I should try to move over to one system fully, therefor trying out automating some in hubitat to understand stability / capability etc.)

I'm trying to access my Webcore dashboard for the first time from a new PC. I'm able to get loged in, but the page says it's loading, and doesn't display the pistons. Any thoughts?

Solved: When in the dashboard, and where it attempts to load, but won't complete, I logged out. Then logged back in and it was solved.

RESOLVED by rebooting Orbi router. Only Hubitat cloud services impacted. I cannot load the dashboard for either the user or built-in versions of webcore. I've rebooted the hub, logged out of webcore and back in again, deleted cookies. Both are running the latest version. v0.3.114.20220203 HE: v0.3.114.20240115_HE - March 10, 2024, except the user version has a date of April 3, 2024. It was working great until a few days ago. My webcore mobile apps are not updating location either.

I wonder if this is also related to "Cloud connection is unavailable."? I cannot enable the Alexa skill either. It stopped working about the same time. No DNS problems or local network problems.

If you are having networking trouble, that can affect the webcore IDE.

I would sort out the network issue you are experiencing with your hub or network.

I upgraded my C8 to a C8PRO yesterday and now I can not get any pistons to load either.

I presume you have backed up all your pistons on the C8 and then imported them into the new C8Pro using that backup?

Yes, I had done the backups and reloaded. I tried so many things I am not sure what I did but they eventually started loaded. As I recall I found that I could load them on my Android phone using the HE app and when I went back to my PC they started loading there as well.