Webcore and Node-red

Yep that is what I forgot to do. I did not add the new nodes. However I just ran the install script and can't find the nodes I just added

Did you add a config node? That needs to be set up first before accessing devices... just add a device to your flow and go into properties. In the server drop down there should be an entry for "Add new hubitat config..." and click on the pencil..

1 Like

Here are the instructions if needed...

1 Like

As an aside - I used to use WebCoRE in SmartThings and it was awesome. I tried it with HE early on but due to growing pains (platform and WC) did not work out very well so went to RM for all things.

Once I discovered Node-RED thanks to this amazing community I ended up moving all my rules over - was easier having them all in a central place (have multiple hubs). Doing this also had the effect of reducing hub overhead as I am using far less apps than I did before. Of course the UI is not for everyone but I've found the visual flow paradigm to be quite logical and powerful.. and I have more control over the environment (memory/space/diag).

1 Like

Well, so far I have not had any issues with Webcore. I have 100's of routines and have moved them all over. Still working my devices over. The wife did not want to go cold turkey. There are a few things that not be able to get to work. Mainly my Adrino boards. I have a sprinkler system and a board that is integrated into my alarm system so that I can bypass it. But everything seems to work very well. The Adrino boards I can't get discovered.

Now for Node-red I have about 50 devices that I was using over in ST. I am still having issues getting the nodes to show up. When I follow the directions I show that I have already installed the node script, which I did from my Linux server. So I know that is one step I can put aside. Here is what I have working. I can use all my x10-stuff through this outside of Hubitat but and ones I get the nodes in I think I have it from there. Here is what I have so far

Did you install the HE Nodes from the palette manager or via the command line?

1 Like

through the command line on my server

Sorry I must be missing something - not sure what you mean... can you see the nodes you installed on the server using the palette manager in the Node-RED UI? If not then they may not have been installed properly..

1 Like

May have to stop and restart Node-Red for them to show up...

2 Likes

What exactly do you mean by "Adrino board"? Are you referring to Arduino boards? If so, are you using the old SmartThings ThingShield? Or a WiFi/Ethernet connectivity solution?

Take a look at my HubDuino thread, as it is a continuation of my ST_Anything work over on SmartThings. It has support for both the old ThingShield as well as WiFi/Ethernet solutions.

Note: During my early testing with the ThingShield, it did not like high-numbered Zigbee channels. I switched my Hubitat hub to Zigbee channel 20 and it connected quickly.

2 Likes

I still have the original ThingShield and have never upgraded. I can't remember how to add it. It has been such a long time

From the ST Classic Documentation...


Pairing the shield

To join the shield to your SmartThings Hub, go to “Add SmartThings” mode in the SmartThings app by hitting the “+” icon in the desired location, and then press the Switch button on the shield. You should see the shield appear in the app.

To unpair the shield, press and hold the Switch button for 6 seconds and release. The shield will now be unpaired from your SmartThings Hub. Make sure to delete from your account if you plan to re-pair it!


Obviously, use the Zigbee Pairing feature in Hubitat's Add Device menu.

1 Like

Installed it from the command line like from here

Did you restart Node-RED like @thebearmay suggested?

I prefer going through the palette manager - much easier. Did you verify the HE Nodes were installed?

1 Like

Smarthings....Like I said I have been using it since you wrote the app. to pair with Hubitat it should find it

Yea the must not have been installed properly. I guess I need to uninstall it and load it from Node-Red

Yeah I would consider doing that.. the palette manager keeps track of certain things so you don't have to. Just go to the palette manager and then the install tab and search for Hubitat. Should be the only one there..

1 Like

Aah this readme/documentation ... :tired_face:
I tried to write a new one, to separate technical from basic usage, but it's just not motivating

This install part is mostly for development/test a copy/paste from another repo. But I think it doesn't change anything (i.e. palette manager will track it) :man_shrugging:

2 Likes

Just need to figure out how to remove it from the server now

to uninstall from the command line: npm uninstall node-red-contrib-hubitat

1 Like

Download the Hubitat app