Water sensor not turning off Water shutoff in HSM

@bravenel , not sure if this is your pervue

So I usually test once a month. I've now set off all my water sensors and HSM is not shutting off the water valve. I have logging turned on for the sensor and the valve (dome) Here is the sensor log

HSM (note: ive also changed use every to off and manually selected the sensors and still no go)

There is nothing in the logs about HSM

Edit: I created a quick RM rule, sensor wet, valve closed. Worked fine.

You've got to show HSM setup and HSM logs.

I guess you mean this?

I get nothing in the logs (live or otherwise) from HSM only from the water sensor. (if there is a log button in HSM I can't find it)





On the App Status page for HSM, click on Events.

I just set up HSM on a new hub, with a valve and a water sensor. When the water sensor got wet, it closed the valve. I don't know what's going on with your system, but I don't think HSM has a problem here.

Every time anything happens with HSM it creates an event that is in the Events page from App Status page. Like this:

HSM is working OK in my setup as well. Water alerts are registered:

and a (virtual) Valve is controlled:

I'll go ahead and delete and recreate hsm to see if that solves it...

Deleting HSM and recreating worked. Must have been some sort of corruption in it. If you want I can send you my last backup on my PC so you can examine it.

No thanks.

1 Like

FWIW, I had a similar issue where I could see the leak sensor was triggered (and kicked off an RM rule that had it going wet as a trigger), and verified that HSM water was armed, and actions were configured, yet HSM didn't do the required action.

I no longer use HSM for water leak alerts.

2 Likes

Interesting. I hit this once as well, but thought it was a problem with the sensor, but then I did see it in the activity log. Was a stressful day so never followed up.

Hmmm...

1 Like

This is known to work, demonstrably so.

Proof by example? I don't believe there is any claim that it doesn't work in general, but three of us have now reported cases where a leak sensor going wet does not result in HSM actions even though that same sensor is configured in HSM, water is armed, and actions are configured. In my observations, the sensor going wet did trigger an RM rule, so we know Hubitat saw it.

I was able to repro this and described what I was seeing in this post. But it wasn't worth pushing on as I could do what I wanted to do in RM instead of HSM.

1 Like

I'm eager to see some evidence that HSM doesn't close a valve when it is supposed to. The code surrounding this is dirt simple: if there is a valve selected, and there is a water alert, the command to close the valve is sent. Logs that demonstrate a water alert that doesn't close a valve would be useful.

It's important to note that if there are other things that are being controlled by HSM in response to the same alert, such as lights, that it is distinctly possible that a weak Z-Wave mesh may not convey all commands to all devices. We certainly have seen evidence that this happens, not specific to HSM.

We will add more logging to HSM specific to it issuing these commands.

1 Like

The problem that I was able to repro at will back in February wasn't specific to closing a valve. I also had a text alert and light alerts configured in HSM. When the sensor showed wet, HSM did none of the actions, and there were no HSM events logged at all. However, a rule triggered by that same sensor triggered as expected.

I have screen shots of logs, etc. that I captured then that I would be happy to share with you. OK to send via direct message? I could post here but would want to redact parts of the logs.

Sure, send them. So you're saying it didn't trip a water alert?

Will do. Yes, the sensor raised an event sufficient for an RM rule to trigger, but HSM itself, which was armed, did nothing. Here's the synopsis of what I looked at as I posted at the time:


I accidentally wet a water leak sensor this morning and HSM, though Armed Water, did not take the configured actions. I reproduced at will with this and a different water leak sensor as well (one was Samsung, on was Zooz). Here's what I've verified so far:

  • HSM shows Armed Water and not currently in an alert state
  • Actions are configured including closing a valve, notifications, and light alerts. None of these actions are taken.
  • Both water leak sensors are configured under Select Water Sensors and show in Settings.
  • HSM shows no events related to the water leaks. It is just showing recent arm/disarm of intrusion.
  • The devices are definitely reporting wet/dry. Those are shown in device events and logs.
  • I have a rule in RM to take an additional action (Alexa announcement) when any sensor reports wet. It is being triggered as expected.
  • HSM is shown in "In Use By" for the sensors.

I then went back in the Water configuration, made/unmade a change to dirty the page, and hit Done. After this, it started working again.

This is basically what was happening to me. No alert when the sensor was just in HSM and valve didn't turn off. This is why I offered my db's if it would help. In the end removing and readding HSM solved it.

Download the Hubitat app