Wally sensors

Wondering if any consideration has been give to support the WallyHome second generation devices? They are good quality Zigbee devices with 3+ years battery life and since Sears doesn’t appear to be promoting the platform anymore, those users may want to consider Hubitat. They have a multisensor for water/contact/temp/humidity and a water Shutoff valve.

Has anybody tried the wally sensors with Hubitat?

Thanks!

I had never heard of these. Wally Products - Water Sensors - Water Shutoff Valves | Wally

The water sensor and shutoff valve indicate "Communication Type: Zigbee HA1.2"

@mike.maxwell - Is this something you could interface with assuming we had some interest? I like the look of the water valve . . .

It would probably work with one of the zigbee switch or dimmer drivers

Does look nice. Ip68 means I could use it outdoors for a gas shutoff.

It's the first one I have seen that you could use for that.

Those would likely need the gas company to install them outside at the meter and I would guess need some certification. If you have a ball valve inside the house where the gas comes in to the house, you can use a Dome or similar valve. I use a Zwave one on the gas going to my outdoor appliances.

I have propane. No meter. No gas company. Just a tank with an outdoor valve. This device does confuse me though, why does it talk about Bluetooth and wifi not just zigbee? I’m a bit nervous to gamble $200...

1 Like

Yes, not a DIY project!

Around here the gas company (or their contractor) must do any work from the supply side up to and including the meter. On the house side, work must be done by a contractor licensed to do that work. Many plumbers are licensed for that.

2 Likes

I am not seeing these as available anywhere. I see one on eBay . . .

SmartHome had a listing for it but it's marked as unavailable now. They have a price of $259 on that page.

Hi Mike, last week it looks like Wally Labs (Wally Home) finally shut all down including the cloud application, so I have about $1,000 worth of Wally equipment (shut off valve, hub, and sensors) in two of my houses doing nothing. There are probably thousands of people in the same boat, but don't know it yet as there was no notice and I only found out when I tried to access the app to remotely turn on the water in my home in the mountains. Do you know if there has been any additional testing with Habitat and Wally products?

Wally looks like they pulled the plug on the cloud app and now I'm trying to find a work around. Did you ever get it working with Hibitat?

Unless someone tries including it with hubitat, I have no idea if it will work or not...

My farm, business and lake cabin depend on 6 Wallyhome hubs and numerous devices including two water shutoffs. So any information about compatibility with Habitat would sure be welcome

Sounds like Mike's recommendation boiled down to... have you tried pairing it? Does it work? I see people asking, but I don't see anyone saying they tried.

3 Likes

I was able to mostly set one up for ST (haven't moved to Hubitat yet... one of these years)

I'd imagine it's pretty easy to convert to Hubitat as it's similar

Unfortunately I couldn't get the water sensor (the most important part) to work 100%; it works sometimes, but doesn't always detect

If anyone can figure out what I'm missing, I can backport to ST

(on github: marcosb/SmartThings/blob/master/wally.groovy - I'm unable to post links as a new user)

I'm in the same situation and trying to get my existing Wally water sensors to work with Hubitat. I'm able to pair the devices to Hubitat but then I can't get any communication between the two to work. The device shows an empty "current state" and I see no event history for the device. I have the device type set to "Generic Zigbee Moisture Sensor". Anyone successfully get these Wally sensors connected that can help me out? Complete hubitat newbie here.

If someone wants to loan/give me one of these, ill take a shot at it.

1 Like

I found a SmartThings device driver here: SmartThings/wally.groovy at master · marcosb/SmartThings · GitHub

I followed the app and driver porting advice here: App and driver porting to Hubitat - Wiki - Hubitat

But, I'm now getting this error. Does anyone have ideas?

groovy.lang.MissingMethodException: No signature of method: com.hubitat.zigbee.Zigbee.isZoneType19()

I've got a few extra of these lying around. Want to DM me your address and I could ship one?

just got it working, it's going to require a minor update to some of the zigbee hub code for the water sensor bits, so it's not going to make 2.2.6 unfortunately...

Download the Hubitat app