Wake on Lan

I recall reading that wake on Lan was officially supported. Is this correct? Or is there an app required?

Yes it is supported.
You can try my app..I dont think I ever shared it on HE. It's parent/child so make sure you install both apps.


Forgot to mention. You would need to create a Virtual Switch (with autoOff so it acts as a momentary) that you will link to the app. For example, I have one called Tower and one called Nas that are each tied to their own child app. I then have the switches on my dashboards. My Tower switch is also turned on automatically when I enter my office so my pc comes out of standby and is ready by the time I sit down.

Is that boot me up Scotty? I've been using it for some time works good if it is.

Yup. I guess I did share it :wink:.
I couldn't find the post.

So this app with the virtual switch will turn on my nas using wake on lan using HE?

Works for my Qnap. As long as your device supports the magic packet it should work.

1 Like

It doesn't work for Asustor :sob:

My app doesn't work or the Asustor doesn't support the magic packet?

The Asustor has wake on lan but I think is something proprietary, like a special magic packet because I can wake up with asustor app from my phone but only when my phone is connected to the local lan. Using a vpn with my rpi and my phone I can't wake up the nas, So I think your app is fine.

The magic packet is a broadcast packet...something tells me that it won't get propagated if the source is from vpn device. The benefit of this app is that the packet is sent from your HE hub which is on your local Lan so it should work (unless of course it really is something proprietary)

1 Like

WOL app doesn't work for my Windows 10 PC. Magic packet is sent by app according to logs, but PC doesn't wake up. I've tried to enter MAC address different ways using colons, spaces, dashes and no spaces. I've ckecked BIOS, network card WOL parameter and everything is turned on. I have no clue what else can be the problem.

Check hybrid sleep settings are configured in the control panel. I’ve had older PCs that would not wake up if not using hybrid sleep.

Thanks, I got this working with my desktop.

Had to make a few changes to my windows settings, but it's working.

@aryvin when entering the mac address, only put the numbers/letters. Nothing else.

I had to adjust power settings and bios settimgs. And make sure the setting for the network card was allowed to wake.

At some point windows reverted these setting on its own. With an update I think.

One symptom I had was the magic packet would wake it from sleep but not from shutdown.

1 Like

Thanks, guys.
The Hybrid sleep setting was already turned on. What actually made WOL work is another advanced setting on the NIC called "Shutdown Wake-on-Lan". When I've enabled it, the magic packet start waking the PC from both hibernate and shutdown modes. It still doesn't wake up from sleep mode, but my main concern was auto wakeup from hibernate mode.


You are a genius, this was my problem! Now I can wake my Asustor!! Thanks

I had no idea using the mac without : will work. Thanks for the app!!!!

Ooops... I guess I never included the code to strip away spaces, colons and dashes like I had in ST. Now that it's posted on the forum, I guess I need to make it more user friendly. I will update it tonight.

1 Like

I updated the child app to strip out ":" and "-". Added option to remove debug logging while I was there.


Did you turn it off by default? It seems to be already off, which is good.