Using webCoRE with Hubitat


#105

Thanks. Knowing it's can work in the Hubitat port hopefully will help. I'll dig some more, and post on webcore.co if I can't figure it out.


#106

Yes. I use webCoRE for all my automations.


#107

Brilliant!! Just when I thought I'd not get webCoRE again after moving over. Many thanks!!!


#111

I am just moving over from ST to hubitat and I have installed Webcore. I created my first piston and when I saved it, this showed up in the log below the piston:

║Unable to update setting 'dev' from child app. Open child app 'Hall Light On' on the Hubitat apps page and click 'Done' for faster operation

What should I do about this?


#112

do what it says, you go into the child device (click on the piston) and at the bottom on the page press done. think you have to do this each time the HUB is re booted @ajayjohnm will be able to tell you more and why its needed.
I was going to ask about it anyway @ajayjohnm is this something we will always need to do from now on?


#113

At first I didn't see what you were talking about but then I figured it out. Thanks! Now if I could just get my zooz 4-in-1 sensor to react properly!:thinking:


#114

I added this message to address this issue here. Because of this you have to do this once for every piston added. updateSetting doesn't create the setting like it did in ST so it has to be done manually by going into the child app and clicking done.


#115

Yeah this is extremely disappointing. There are logical operations that just fall on the floor.

You set a global var, the logs say it was set, but you look later and it wasn't set. There seems to be timing issues with other things as well, like setting location modes. Very subtly broken.

Hmm... ok so I purged all data for my misbehaving pistons and put in a few waits to allow global vars to get set before other pistons try to read them and I almost have something that works...

Nah... still hopeless.


#116

If you do like webCoRE and don't want to risk bogging down your Hubitat hub with it, you can use the krlaframboise Other Hub apps/DTHs to create the relevant devices in Hubitat in ST, which will allow bidirectional control, and then use webCoRE on SmartThings to do what you want. You're no worse off than before: it requries the cloud now but did (and will) with just ST, too. :slight_smile: But in the meantime, you get the local advantages of Hubitat for whatever automations (and device control) you're able to keep there.

As you have time or make discoveries, you can move the automations to Rule Machine, native Hubitat apps, the variety of community-created apps (and most are quite easy to port from ST if there are any you like), or even your own apps--they aren't that much harder to write than webCoRE pistons except that webCoRE writes most of the code for you by pointing-and-clicking and prevents you from making mistakes like syntax errors.

That being said, I'm bad at taking my own advice: I'm still cautiously running webCoRE on my hub, swearing to myself I'll move things off it as I get the time. :slight_smile: (Only locked up my hub a couple times, mostly resolved after a point update when a firmware update changed something that inadvertently caused a problem.)


#117

Yeah well it looks like global vars and modes are both out. not reliable enough. I use both extensively so I'm pretty eFFed.

You set a global variable and sometimes it gets set, but sometimes it doesn't. I don't understand how that can even happen. Maybe it is time to go straight to groovy. This is even more broken than SmartThings.


#118

webCoRE is basically its own interpreted language running on top of Hubitat's (and ST's) already interpreted language, Groovy. The fact that it mostly works on Hubitat with minimal changes from ST is pretty amazing, though there are occasional hiccups (I think everything I'm doing works as I expect, but I don't use global variables; I did read and set location mode with success, if that's what you mean; if you're having problems with variables, if they're boolean, maybe a virtual switch or something could substitute?).

But yeah, I recommend learning how to write Groovy apps for Hubitat on your own. There aren't a ton of first-party Hubitat examples, but there are some plus a lot of community apps, and 99% of what works on ST will work here too. There's a thread with differences, and hopefully the official Hubitat Docs wiki will have more soon too.


#119

It really is pretty amazing that it works as much as it does, but I'm a bit frightened by the under the hood architecture after what I've seen today.

In any event, I've found a workaround-- you have to set globals in a repeat loop with a 1 second wait, until you can verify they're set. After doing it this way I've just simulated 4x leave/returns and it all worked as designed. It's a little embarrassing to be blasting commands and hoping 1 of them sticks, but whatever.

For my setup, my rooms don't really use globals much, just the home/away stuff.


#120

Have you tried to set the global variables more than once? Say set it 3 times in a row with a slight delay between. Perhaps it will stick on one of the attempts.

I use webcore on ST, haven't tried it on Hubitat yet. I have many custom DHs SAs on ST so I haven't fully migrated to HE.


#121

Yeah, I've been doing something like this:

repeat
do
x2 Set variable {@aGlobal} = foo
wait 1 seconds;
until
{@aGlobal} is equal to foo
end repeat;

This seems to work better but I'm not sure its 100% yet.


#122

A WebCoRE piston can still be timed out I believe. if that did happen and there was a global var set later in the code it wouldn’t happen.


#123

Is anybody using Pushover with webCoRE?
I've defined it in webCoRE but cannot select it in any of the options for notifications in webCoRE.
I can send an SMS but with the limit to 10 per day, I was hoping to use Pushover.


#124

Is this the right discussion group to help me with this?

I've been using Webcore on SmartThings for about 1 yr. Recently I got a Hubitat so that I can get the advantages of local execution. But I cannot log into Webcore. I loaded the Webcore apps into Hubitat. The main Webcore app is OAuth. I named this instance different from my ST instances. But when I go to the instance, log out, go to the Dashboard, and enter in a new code that I just got, I always get a message that there was a problem loading the dashboard, try logging out. What do I need to do to get the Webcore dashboard working with Hubitat?


#125

What type of device are you selecting it as in webCoRE? Pushover should work as either a Notification device or a Speech device. Both accept a plain text string. I can't imagine why it wouldn't work. However, I am not using webCoRE on Hubitat these days.


#126

I have subscribed to Pushover and defined it as a device.
I select it as a device in the piston but when I select either 'Send Notification' or 'Send PUSH notification', nothing happens.
For Send Notification I get the following error in the logs.
Error executing virtual command [Pushover].sendNotification: (3ms) groovy.lang.MissingMethodException: No signature of method: app15413269896641203846002.sendNotificationEvent() is applicable for argument types: (java.lang.String) values: [test]

For Send PUSH notification
Execution stage started
+644ms ║║Cancelling statement #2's schedules...
+4325ms ║║Executed virtual command [Pushover].sendPushNotification (1ms)
+4372ms ║╚Execution stage complete. (3778ms)

Which seems to me like it has cancelled the notification.

Hence querying if anyone has it working with webCoRE.

Here is the piston.
image


#127

SendPushNotification is probably for the SmartThings mobile phone app. So, that is probably a dead-end.

Not sure how webCoRE has implemented the use of Notification devices. It should just pass the text to the device's 'deviceNotification(message)' command. Not sure why it is trying to call 'sendNotificationEvent()'.

Try adding your Pushover device as a 'Speech Synthesis' device, then having webCoRE issue a 'Speak' command.