Using webCoRE with Hubitat


#83

Looking Ady’s GitHub it appears that there were some updates to WebCore dashboard done 13 hours ago. My installation still works (at least when I open the dashboard via a piston in the Hubitat app list) but I haven’t updated anything recently.


#84

I now see the update. The comments say:

03/23/2018 >>> v0.3.104.20180323 - BETA M3 - Fixed unexpected dashboard logouts, updating image urls in tiles, 12 am/pm in time(), unary negation following another operator

So it looks like that may be causing my problem.

I guess the larger problem is whether the Hubitat community will be able to keep this version compatible with the webCoRE backend?


#85

Just got my hub and installed webCoRE.
Defined a few devices to see how it works with HE.
When I select a physical device (motion sensor) the only thing I can select is 'status'. No attributes for motion, temp, illuminance etc.
Anyone else seeing this.
EDIT: Just realised that when I actually save the piston it doesn't put the device in but says my Hub Name.

image

EDIT: Deleted everything and started again and now I can see the device attributes OK.
Must have messed up the installation somehow.


#86

I ran across this too. It’s a clash between the id of the location (your hub) and the device you selected. Both had an id of 1 in my case. The ids of both are numeric in hubitat rather than GUIDs like in smartthings. I believe I had to remove the device and re-add it so that the id would be incremented at that point to something other than the current location id.


Patched webCoRE for Hubitat (2018/09/09)
#87

Has anyone seen any issues with piston restrictions tied to sunset. I’m in the process of moving over lights, motion sensors and other devices, I’ve been doing it based on pistons, I have one simple piston.

Turn on lights with motion, then turn off when motion is inactive. Only do this after sunset. I set it up last night, and it seemed to be working fine (as expected), I ended up staying up until after midnight, and when I walked into the room , the lights did not turn on. I was surprised. Went back into my piston and removed the sunset restriction and it started working again. I It was late so I did not go too far into it, only thing I could figure was that it only went from sunset to midnight? Honeslty I dont even know if thats how it worked with ST, but I’m pretty sure that using sunset assumed sunrise as the end time?


#88

It might reset after midnight. You might need a “after dusk and before dawn” restriction instead.


#89

I agree, and will do that if necessary, was just looking for confirmation. I try to make my pistons as simple as possible when I can.


#90

I am getting the following error when using the ported version of WebCore - anybody have any ideas on how to fix? Executed [Kitchen Desk].setLevel (18ms)
+1365ms ║║An error occurred while executing the event: groovy.lang.MissingMethodException: No signature of method: com.hubitat.hub.domain.Location.hasCommand() is applicable for argument types: (java.lang.String) values: [setLevel]


#91

setLevel shouldn’t be “string” right? It only takes a numeric value.


#92

Check this out Patched webCoRE for Hubitat (2018/04/10)


#93

Yes - I am sending an Integer.


#94

I read through the thread and was rather intimidated in being able to install WebCore on Hubitat. Thanks to everyone's work in porting it (and the developers), it turned out to be relatively easy and straightforward. Here are the steps to install:

  1. Go to the GitHub repository

  2. Click webcore.src

  3. Click webcore.groovy

  4. Copy the code. You can click the Raw button to display just the code, select it and use Ctrl + C.

  5. Go to the Hubitat app.

  6. Click Apps Code.

  7. Click New App.

  8. Paste the code (you can use Ctrl + V).

  9. Click Save.

  10. Click OAuth.

  11. Click Update.

  12. Repeat for the other webcore app components:
    On GitHub (click Back in browser four times), click webcore-storage.src. Click webcore-storage.groovy. Copy the copy. Go to Hubitat app. Click Apps Code. Click New App. Paste the code. Click save. Click OAuth. Click Update.

  13. On GitHub (click Back in browser four times), click webcore-piston.src. Click webcore-piston.groovy. Copy the copy. Go to Hubitat app. Click Apps Code. Click New App. Paste the code. Click save. Click OAuth. Click Update.

  14. On GitHub (click Back in browser four times), click webcore-dashboard.src. Click webcore-dashboard.groovy. Copy the copy. Go to Hubitat app. Click Apps Code. Click New App. Paste the code. Click save. Click OAuth. Click Update.

  15. In Hubitat app, click Apps.

  16. Click Load New App. Under User Apps (at the bottom).

  17. Click webCoRe.

  18. Click Next.

  19. Enter a "Name" for the webCoRe instance. (I included "Hubitat" within the name to make sure it doesn't conflict with my ST install - don't know if needs to be unique.)
    There's an option to (dis)allow collecting anonymized data (I don't know if the Hubitat port actually sends this data...?) Select whichever is your preference.
    Enter a password.

  20. It will ask to select actuators and sensors, and devices by capability. Select all that you want WebCore to access for each the options. (You can change the selections later.)

  21. Click Next.

  22. Click Done.

That should be it, but let's make sure.

  1. Click Hubitat WebCore.

  2. Make sure the actuators and sensors saved properly (from the above step), by clicking Settings.

  3. Click Available Devices.

  4. Check if your selections show correctly, and if not, reselect them.

  5. Click Done.

  6. Open Dashboard in a new tab (eg right-click, Open link in new tab, or however).
    Use as WebCore as normal and consider donating to the developers. (This is especially true for @Roguetech!)

If anything here is incomplete or incorrect, I will update - just tell me what I got wrong.

edit: I've had trouble getting WebCore working with these steps, and removed it and readded a couple times to get adding a piston to work. The "actuators and sensors" don't appear as available to WebCore. I'm not sure what the secret sauce was that finally worked for me. I think the trick was to follow the steps above, then open WebCore and login, then in Hubitat go into "Hubitat Storage" (which only appears after going into WebCore). When your devices are registered in Hubitat Storage, then they will appear in WebCore. I'll try to retest it and capture what's required (and what all I did that didn't actually help).

Credit for numbering to mpoole32.


Smart switches
Patched webCoRE for Hubitat (2018/09/09)
Triggered rule with Delay
#95

Is there any technical barrier to creating a fork that would work on both ST and HE? Do the commands exist in both to get the system name to say If HT, then capability = button, else capability = pushableButton?


#96

There isn't. I started off working on making the code flexible to run on both systems, however, owing to a new job and some other life changes, I am not able to find the time to work on this at the moment,
I hope to resume this project at some later point (unless someone else starts working toward this goal in the mean time.)


#97

you have done some awesome work already ... thank you for that. i was thinking of taking this on but probably dont have the time i would need to get this done done. :slight_smile:

do you have a list of issues on github that community members could pick off one by one as they have time and submit a PR for each? that would help distribute the load and we could all help get this done.

thanks.


#98

That's a great idea! :smiley:
I'll try to spend some time and break out the tasks coming weekend and then post it on the forum forum requesting for help.

Also, thank you for your kind words!


#101

I'm can't get Location Mode, weather or presence (using Life360) to work. Any suggestions on how to begin fixing any of these? Without any of these, my Hubitat system is pretty much a wasted Ethernet port.


#102

I assume you mean using WebCoRE.
If so you might want to go to the webCoRE forum and ask for guidance or open a new thread on the Hubitat forum but include information of what you are actually doing.
Just saying you cannot get it work with no information makes it difficult for people to advise you.


#103

So other people have been able to get Location Mode, weather and presence in WebCoRe on Hubitat to work?


#104

I use Location Mode a lot....

and Presence using Life360...