Using NFC tage to control devices remotely

I found the following instructions online to allow device control remotely with NFC tags, but no success.[MakerAppID]/devices/[DeviceID]/[Command]?access_token=[OAUTHAccessToken

Am I missing something?

Well, that's definitely not a complete set of "instructions" since it assumes you have a Maker API instance set up (do you?) and don't have cloud access disabled, and that you have the right device ID, command name, and some way to do an HTTP GET on your device in response to the NFC tag.

But, yes, if you have all that, this is certainly one way you can make it work. If it's not working, I think you'll need to share more about your setup or where you found this.

I use NFC tags for a couple of automations.

I created shortcuts on my IPhone that calls endpoint triggers.

That is a pretty simple process, your needs may be more complicated so as suggested maybe a bit more context.

Hi @amali01, your post doesn't say what platform you are using (Android/iOS), if Android, go to this post How-To: Program NFC Tags/Stickers For Automations In Hubitat it will show you how to set up a local end point using rule machine, when you are going through the tutorial, change out local for cloud.

If you must have cloud control, keep in mind security, anyone who gets their hands on the RFID tag will have access to your system.

Im using iPhone shortcuts automations. I have several other nfc tag automations setup using maker api for within my home wifi. This automation im working on is to control a Myq garage door from a nfc tag attached to my car dash. Currently I have to wait in driveway for iphone to connect to home wifi. This cloud solution sounded like a it might work.


If you use a cloud endpoint as opposed to a local endpoint then you don't need to be on your local network.

Looking at this again, you've got the wrong format for a cloud endpoint. You can't just replace the local URL with; you'll need to use the format shown on-screen by the Maker API app. If you don't see it, make sure cloud access is enabled for that Maker API instance.

The format will resemble:<your-guid>/apps/<app-id>/devices/<device-id>/<command>?access_token=<access-token>

Perfect example of don't believe everything on the internet. Your guidance worked. I did not have cloud access in maker api turned on. Once I did that the correct string for remote access was presented to me. All is good.


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.