Using new aeotec dual micro driver - status issues

I have several Aeotec dual micro switches in my house. Most have been set up with the virtual switch configuration done manually. One of them I used the new Aeotec dual micro driver. It created its child switches automatically. I then created similar rules for all of them the same way. That all worked.
The problem is that the new driver does not update the status consistently. This causes issues with Alexa of course. I can control them via the device in hubitat but the status does not always show properly on the dashboard.

Any ideas?

FYI - I never had any issues with this switch using Wink. Also all of the other door micro switches work fine

Are they actually aeotec micro switches or are they the newer NANO switches?

They are the dual micro g2 switches. The old ones are way easier to wire, albeit they are a bit larger. They are half the price as well. I have 3 of them in the house. I do have one single switch nano as well.

Then they should work, were you using another driver before? If so your need to do a clean before trying the driver. I have a temp clean driver I use for these things.

You can find it here.

Replace the device driver with that. Then hit the cleaning buttons and then replace the driver with the new built in one and you should be good :+1:

That sounded great, but now the switch will not work at all. I can see the state in Huibitat now, but cannot control it. If I flip the light switch, the lights turn on, the state updates in Hubitat, but I can not control it FROM Hubitat.
I tried doing the factory reset, excluding it, re-adding it and changing the drivers back and forth and could never get it to work again.
Any idea? Is it holding onto some old driver data?

If you do this is will clear any old data but then it should automatically select the built-in driver.

If you have done the about and it selects the correct driver DO NOT do this your giving it issues again like before.

If you're willing exclude it factory reset it. Then include it then ensure it has selected the correct driver.

Yeah - that's what I did the first time (after trying your clean driver procedure). I Excluded it, factory reset it, and then included it back in. It automatically used the built in driver, created the child switches and then I tested it. It would show the status if I manually turned the light switch on, but there was no control from the software side. Strange as that's the opposite of the issue I started with.
One thing I noticed is that it says PENDING in the Scheduled Jobs for a logsOff handler. Not sure what that means though.
Also - maybe this is normal, but would the device network ID change each time you exclude/include? I did record the values though. It is 20 now.

Are these helpful as well?:

  • deviceType: 3
  • inClusters: 0x25,0x31,0x32,0x27,0x70,0x85,0x72,0x86,0x60
  • outClusters: 0x82
  • deviceId: 17
  • manufacturer: 134

FYI - I have several other Aeon Dual micro setup the old way - with a custom driver and virtual switches. they are working fine.

This is normal.. Most HE drivers auto disable the debug logging after 30 minutes..

Totally normal.. This gets assigned during include

best to ask @mike.maxwell now then, as its his driver.

What firmware is it on? You can used the basic z-wave tool to check if you don't know and @bcopeland @king is working on a amazing z-wave firmware update tool currently! If you ask nicely he may be able to add the firmware for this device to his list :slight_smile:

1 Like

this is normal

also normal with Z-Wave

maybe a firmware age issue, don't know, these were't the most popular of devices, I only have one of these, and it's at least 5 years old.
If you turn on/off the parent device do both of the children turn on and off?

1 Like

There is no reaction if I turn on/off the parent or child. I’d love to check or update the firmware. Not sure they have been updated in a very long time. Pretty sure Wink didn’t have that ability either. I used Wink before this.

Something Interesting though. I have a feeling there is a bigger issue here. I also have an Enerwave double switch. Both this Aeotec and the Enerwave have the status update issue. I did not realize this before. The Enerwave is at least controllable via the parent switch. Both work via Alexa, but if the light is on, I have to tell Alexa to turn it on before I can tell it to turn it off.
Never had this problem with these switches in Wink.

By the way - can I ask what switches you use/recommend? You mentioned that the Aeotec ones were not popular. No one at the time made any hidden switches. Haven’t had any better luck with the Enerwave. What do you like?

Did you check with @bcopeland? - he has written a firmware updater driver that can update your firmware. I've been beta testing it and it works great. The only issue is I do not think he has the dual micro firmware - you might have to get it from Aeotec directly.

For dual switches the Qubino 2 relay works well and is supported - I'm using both the Aeotec Dual Nano and Qubino 2 Relay. The dual nano has some major lag in event firing but maybe that's due to one of the switches not having a load + also there is currently no native driver for it.

1 Like

The dual switch wasn't popular, the single switch and dimmer were very popular, ive personally used over 100 of them.

All - no luck here with any of my dual switches - both Enerwave and Aeotec micros. They work but do not update status. I only use them with Alexa to be clear. i have to tell Alexa to first turn them on before I can turn them off if they are out of sync. I am technically using several combinations of drivers and virtual switches as a test. I am starting to think it is something to do with the virtual switch setup. I really need this to work as I have 5 Dual switches in the house. Any other ideas would be very welcome.

Did you check the parameters of the Aeotec devices using the Basic Z-Wave Tool as previously mentioned? Specifically 80 - it should be 2 (Basic CC) not 1 (Hail). There may be other parameters to check as well but that's the one that leaps out at me.

I have Aeotec Dual Nanos but I think that param is the same. You can find a list of the parameters for that device online with some searching.

edit: You mention virtual switches - are you including the actual switch(es) in the Alexa app or using virtual ones?

Thank you. That is a good idea. I had not heard of this tool - just the firmware tool. I have sent an email to Aeotec to get the new firmware.
I’ve created the Basic z-wave tool driver, switched to the new driver, but none of the report buttons do anything. I entered 80 and ran the report as well, but still nothing.
Any ideas? I can’t seem to win with this Hubitat software.

What is the actual device we are working with here?, is it in fact an aeon dual micro?, or some other device...

Yes - they are Aeotec dual micro switches - model dsc17103. I have 3 of them. But I want to make sure it is understood, I also have 2 Enerwave RSM2 dual switches that are doing the same thing. They all have status update issues. Sorry so long between responses. Been in and out of work with this Covid stuff.

When you say you attempted to set parameter 80 with the zwave tool, did it actually set it, were you able to read parameter 80?
Parameter 80 is specific to the aeotec devices, and the driver will likely only work with the aeotec devices.

I get no reaction to any of the ‘buttons’. I can’t set or read any parameters. Can you explain how to use this? It seems pretty straight forward, but maybe I am missing something.