Updating C-7 to 2.2.5...How long does this take?

My first update since getting my HE. This seems to be taking a long time. It's been about 45 min and the light is still blue and I get a "Site cannot be reached" message when I try to access it. Is this normal? Should I unplug it and try to re-boot it?

1 Like

Hold on let’s see if we can get Support to answer before you unplug... @gopher.ny @bobbyD

1 Like

While we’re waiting can you try using port 8081 (http://yourHubIp:8081)

1 Like

Done. I have the Hubitat Diagnostic Tool now. Says it's running hub-

Okay, worst case scenario you should be able to revert then. Support should be on shortly.


Please give the hub a reboot from diagnostics tool, let's see if that brings it up.
If not, yes, a rollback it the way to go, and I can take a closer look at the hub later.


Had to look up the MAC address, but re-boot in progress.

1 Like

10-minutes later and still getting "Waiting for Hub to reboot" message and the spinner indicator.

Rolling back to

Ok. It's back up and running again with I have Dashboards and can control things again. What should I do now?

On a non-related topic....I just looked outside and WOW it's snowing hard!


Also having this same problem. Still getting things configured after just receiving my HE. Thought I’d try a firmware update. No progress after a very long time. Diagnostic Tool works. So I’ll try to rollback to last version, I suppose.

1 Like

You can also try a Soft Reset with restore.


I haven’t backed anything up yet. So maybe I’ll do that tomorrow and try to reapply the update, then do a soft reset and restore.

Hub should be doing an automatic backup nightly.

It’s possible there were other backups. I only see one from about 45 mins ago. Again, just getting started and only plugged in my HE for the first time yesterday.

Interestingly, after rolling back to the previous version ( and pulling my MAC address from hub details (for the Diagnostic Tool login), I checked and downloaded the most recent backup and then returned to the diagnostic tool. When I clicked restore previous version it listed the new firmware ( as the restore option, which I chose to restore. For whatever reason that fixed it.

So to recap. I upgraded, which failed to launch to UI after >45mins, then restored to, then restored back to It successfully loaded from the restore.

Odd. But it’s now working on the new version.


I had no trouble upgrading one of my C-7 to v2.2.5.119:

I understand some are hitting some unseen issue, and although it isn't fun to be on the sad side of the issue... at least now you know it's not everyone :frowning:


I just tried @george107789 's solution and that worked for me also.

Updated to which failed and got stuck during the update process. Reverted to using the Hubitat Diagnostic Tool. Then later reverted back to, and now it's working fine.

I suspect that if you had used the diagnostics menu to reboot the hub at that point you would probably have booted up in 2.2.5. The fact that you had a good install of 2.2.5 to revert to seems to indicate problems w/the hub starting the reboot after the update may be at the root of a lot of these "failed updates."

Entirely possible. As a newb, failed upgrades leave me poking whatever button works :wink:

It seems like there are several people having this problem. So perhaps one of them could test that theory.

1 Like

Someone else posted they did that, IRRC.

And you made no newb move here, you got yourself up and running in a clever manner...better than many others would accomplish. Well done! :slight_smile: