Updated to - Lost Mesh - No Active Hubs Avaialble

I have three C7 hubs. Two control devices. One controls the integrations and rules. Devices on the two device controller hubs are linked to the third controller using Hub Mesh. After the firmware update, all linked devices on the third controller hub show as "OFFLINE." Upon checking the Hub Mesh settings, I noted that the the two device controller hubs are NOT listed as "Active hubs."

I am running an Asus Zen wifi AX router. Multicast is disabled on the router. All hubs are ethernet connected with static IPs. I am NOT using Hub Login Security. This configuration worked just fine until I updated firmware.

Any help will be appreciated.

Not sure if 153 is supposed to have this fix or not, but you might consider this to get it working for now if not:


Did you update all three hubs to the latest firmware? Depending on what previous release your hubs were/are running, they may now be a mismatched set. If not, make sure all three hubs are upgraded to the same version.

1 Like

Yup - All hubs on the same version - Getting ready to try bertabcd1234's suggestion. Will advise if that works. - Thanks for responding.

1 Like

This did not appear to work. Tried on all three hubs and rebooted all three. Still not seeing the other hubs in "Hub Mesh" "Active hubs and linked deveices still show as "OFFLINE."

Do your meshed hubs show up on the Hub Mesh (settings page)?
Can you hit the "reconnect" button? What happens when you do that?

change all your hubs to TCP for hub mesh, save it, shutdown all hubs, pull power from wall, wait 1 minute, boot up all hubs. It will take a minute to connect. I just had this issue 2 days ago

EDIT-the steps above i took prior to migrating to .154 to be safe, then upgraded. Hub mesh came back but took a few minutes to become functional.

I guess if nothing else works you could try rolling back, switch to TCP for hub mesh, then upgrade again


My meshed hubs do not appear s "Active hubs" on the "Hub Mesh" setting page. Selecting "Reconnect" displays a green bar stating "Hub mesh reset, reconnecting now" but nothing else happens.

Thanks for the response - But please excuse my ignorance... Where in the UI do I change the hubs to TCP for hub mesh? Best regards - J

Actually i think you shouldnt have to.
After you update all your hubs to a release beyond

Things should come together again. Have you powercycled them all?

All of my hubs are on and ALL have been power cycled - Still NO active hubs showing on the Hub Mesh setting page.

Any "interesting" network setup? I don't think multicast should matter for TCP (not a network expert; someone correct me if that's wrong), but maybe any firewall rules like blocking certain ports?

1 Like

This is a very good hypothesis, as I believe @gopher.ny may have also changed the port number that is used by Hub Mesh in a recent release.

1 Like

That checks out

  • Removed UDP hub mesh option (it's TCP only now) and moved TCP hub mesh option to use port 8083 instead of 8082.

I'm running both Firewall and stingBox on my network. I'm only blocking port 8443, There have been no configuration changes to these devices. Again, my hub mesh was working until I upgraded the firmware yesterday. Thank you again for all those offering assistance.

Are all three of your Hubitat hubs on the same vLAN? If not, it sure sounds like a firewall issue blocking the new Hub Mesh port. :thinking:

All three hubs are directly connected to a NetGear GS324 gigabit switch which is connected directly to my router. I also confirmed that monitoring of the hubs was turned OFF on my firewall (apparently I did this sometime in the past). What port is being used by Hub Mesh?

TCP 8083

While I appreciate everyone's efforts, this issue remains unresolved. I have disabled my firewall and stingbox and rebooted the hubs and they still don't display as active hubs on the hub mesh settings page. Again - the hub mesh worked until I updated all the hubs to I remain concerned that something in the update is the root cause of the problem.

Maybe @support_team will have ideas for other things to look at.