[Updated] Presence Central

community_app

#61

Andy,

I had the PC app installed from months ago, so I went through and deleted everything except for the Container app, same issue

Rick


#62

Anything is the logs?


#63

Andy

No driver code, only apps code is Cobra Apps, Opened Apps and locate Cobra Apps
image
Select the drop down, select PC, clear the selection to select Install PC, get the error


From Live Logs

Rick


#64

Are there no errors when you try to install PC


#65

You are trying to install PC directly from The container I assume?


#66

None, only what you see in the logs :frowning:

And yes, directly from the container

Rick


#67

OK, went back even farther

Removed the Cobra App, only thing left is the App Code, here is a snippet
image
image

From main daskboard, select Apps, select Add User App, select Cobra App
Select Cobra App from Apps, selected done
Selected Cobra App again from the Apps, selected done again (still no option to select any apps from the container)
Now select PC from the Container, cleared the selection to get to Install PC, get the error

Here is the full log from start to error

Tried to install several others and still get the error


#68

@bobbyD, anything on the HE side that could be causing this issue?

Server 500 error when attempting to install Cobra Apps

Rick


#69

It seems a few of my apps have gone kaput since the update.
I’ll look at the code as I have an idea what it might be.


#70

@Cobra Awesome to hear that you're aware that there maybe an issue. I was about to reach out to you regarding Presence Central causing that error.


#71

I noticed a problem when trying to create a new “group 2” event. It wouldn’t select.


#72

Still not working for me tonight, same error code 500

Rick


#73

I assume you didn’t get any errors when you installed the ‘cobra apps’ container?

Andy


#74

Guys
I have updated the code for Presence Central to include a fix for the updated UI issue
You need to update both the parent and the child apps

New versions:
Parent 2.3.1
Child 2.8.1

Andy


#75

@Cobra,
Thanks Andy, awesome stuff.
I'll go grab them now and let you know how I get on.
Nic


#76

Guys
One thing to note:

After updating the code, if you have any existing child apps configured then you need to open each one, check the configuration and save it
As the code has changed quite a bit this MUST be done to update the configuration.

Andy


#77

@Cobra, That's resolved the UI issue for me so I'll continue testing it.
Thanks for the wickedly fast support Andy. :+1:


#78

Great!
Thanks for the feedback

Andy


#79

Not sure if this is intended or not but I noticed that when I hit "Done" at the page that shows all of the presence automation apps it takes me back to the settings for the last automation app that I was editing instead of back to the HE Apps screen.


#80

Nope..
Not intentional.
This has only happened since the new UI

There is one thing that sometimes works.
Hit the check for update button on the parent and wait for the refresh before hitting done.

BTW
all the apps save ok.. it just seems to do this funny thing sometimes
If nothing else works you can always just click the link back to the apps page

Andy