[UPDATED] - Message Central - Make your home speak

What speakers are you using?

I am using Sonos Play 1's and a Ikea Symphonik shelf

That would be awesome! Thanks!

link seems to be bad?



Hey @Cobra - I used to use Message Central but axed it when i was unsure what apps were making my hub unreliable (along with all other 3rd party apps). I'm back now, more experienced and ready to try the app again but it's gone. I registered on hubitat.uk a long time ago....any news on when your apps will be back?

Can you or someone please share the source with me? Privately if you'd prefer...

I have already completed some updates on Message Central.
It will be available soon on my website.

Hopefully the website will be open soon
Everyone should get an email as their membership is activated.


1 Like

Hello Andy,

Are you planning to add mobile app message? I'm eliminating all Pushover notifications and I don't see how to use the mobile app messaging, thanks.

Yep, Message Central needs a bit of love.
I have a few plans to add email and HE messaging to it soon.
No eta but it should be quite soon.


Not sure if this is supported or not, but I am trying to play an mp3 from my Qnap Nas. I have created a network share for the folder where the file is located. My Echo Show will say the name of the file, but not play it. There is no password required to access the file.

Is this possible or am I trying to do too much?

Are you creating a share, or virtual host via the webserver?
Reason I ask is, one would be http:// and the other would be \\192.168.1..... etc.

I suspect you cant open that URL above in a browser? But if you can then it should work.

1 Like

Qnap calls it a share link and I just copy the link they give me.

Using the HTTP://... I can go to the folder in a web browser. If I do \\192... it does not allow me to hit from the browser or explorer.

Http test

\\192 test

Using the Qsync? Yeah, I think that just creates the link, but to play it would be extra activity.

Enabling the WebServer will create a "web" shared directory, where you can copy any files to.

Then you can place any file in that "Web" directory and use (in my case)

Also means you can use this directory for hosting any Dashboard images. (wu being a sub directory in the Web directory). Works very well with the Qnap.

I had the web server set up but created a new folder with guest privilege's. I can go to the folder in the browser, but the mp3 is still not playing.

This brings up the files in the web browser:

Using http:// or x-file-cifs:// does not work. It appears you may have updated the code because I cannot find the code referenced cade to try to modify it.

Do a search in the code for:
def soundURI = "http://" + pathURI + "/" + sound
(Around line 1638 in my copy)
Try changing the http://
To: file://

Do I have some other configuration set incorrectly?

Try removing the spaces in the name of the file. Use underscore instead of space if needed, as the current name will end up being 21%20-%20Goodnight%20Daniel.mp3

I still cannot make it work. What am I missing? Anyway that you can think of that I can test alternatives?



If I remember correctly (it’s been a long time since I wrote this) MC uses the ‘playTrack’ command to play mp3s
Have you tried the url directly in the speaker device page using this command?
This will confirm if you have the url formatted correctly


On my Echo Show I cannot get to the files using Silk or Firefox. I don't know all the differences between the web browsers but, on a computer I can get to the files on Chrome and Edge, I cannot get to them on Firefox. Internet Explorer brings up a file explorer window with the correct file path.

So if Silk is similar to Firefox there might be some sort of error there.

Does anyone have an mp3 file I could try? If there is a url that you know works that would be great. I have tried multiple mp3's and multiple speakers without success.

Wondering if there is something wrong with my files...

Try this...

https:// cobra-apps.co.uk/testfile.mp3
remove the space before cobra-apps


1 Like