[UPDATED] - Message Central - Make your home speak

Yes :slight_smile:

Any ETA on mobile app support?

I'm sorry, I haven't had any time to look at this.
As I said before, this app is due a major overhaul soon but no ETA


Gotcha, think I got it modified myself.

Iโ€™m half way through a major update of Speaker Central.
This will include the facility to also send messages to the mobile app
I have it currently configured to send certain messages when Iโ€™m not home
For example, leak alerts are spoken, unless nobody is home in which case it gets converted to a text message that is sent to the mobile app.

Lots of work to do atm. :slight_smile:



Not sure why I keep getting this error when trying to install the Parent App for Message Central?


Try commenting out line 63.

parent: "Cobra:Cobra Apps", // ******** Comment this out if not using the 'Cobra Apps' container ***************

@Royski Thanks for that info, got it working now.
I'm not sure how I missed getting a notification from you on this post.

But thanks again.

1 Like

I am trying to play a local .mp3 file:
Enter URI to mp3 files (e.g. mydomain.com/files or localwebserver/files or IPaddress/files)*
Enter mp3 name here (e.g. alert.mp3)*

but I get a "...server cannot be found..." error. I have tried all kinds of things like putting the slash after "share", putting a slash before the .mp3 file name.

using the link in Notifications works like this:

What am I doing wrong?

Can you open the link in a browser?

I can if I use file://...

The x-file-cifs:// works with notifications

This was designed to work with a webserver hosting the mp3 file
It was never designed to work with a network share

Unless you can play the file from a web browser using http:// then it is unlikely to work for you.


1 Like

It plays in Chrome with:

Using what driver? To play a file in Chrome it has to be accessible from a public webserver. Not a file server.

It is on my NAS on a Linksys router

Do a search in the code for:
def soundURI = "http://" + pathURI + "/" + sound
(Around line 1638 in my copy)

Try changing the http://
To: file://

I donโ€™t know if this will work but itโ€™s worth a try

If the file server is serving it via a webserver, then yes, that will work.

Your nas is on your router? Or connected to your router? Or do you mean a HD connected via usb to your linksys router (what I would call a psuedo NAS)?

If you mean the last thing...it is likely working because those will be served over an HTTP and a file server. So, you are getting the HTTP file when you use the link.

Try changing the http://
To: file://

Changing it to "file://" did NOT work,

However, changing it to "x-file-cifs://" DOES work!

1 Like

It is a USB HD connected to the router.

When I next update the app, Iโ€™ll remove the hard coded http:// or may put it on a drop-down so people can use whatever option they like or maybe just allow freeform text there


1 Like