[UPDATED] - Average All (Temperature, Humidity, Illuminance, Ambient Pressure & Motion)

community_app
community_driver

#124

Bob
I haven't
Completely forgot!
I'll have a quick look now.

Andy


#125

Version: 1.3.1 just uploaded with (hopefully) the if applied
Have a try and let me know how you get on.

Andy


#126

Oh dear. It's big apology time.
I updated and was still seeing the same error.
Strangely I was only seeing it on only one of my Virtual Lux Sensors and not the other.
Further investigation showed that I was using you old original driver. :blush:
Updated and now its OK.
Sorry about that but I was convinced I'd changed it.
Once again. Sorry......... :face_with_head_bandage:


#127

No probs.. the code needed cleaning up anyway :slight_smile:

So long as it works for you now.

Andy


#128

Updated driver to V1.3.2

Fixed issue with temp unit selection & LastDevice

Andy


#129

Hey @Cobra I got this updated but I'm still seeing this in my logs for the device:

2018-11-15 11:22:47.627 am errorgroovy.lang.MissingMethodException: No signature of method: dev15423023220091490990862.lastDeviceHumidity() is applicable for argument types: (org.codehaus.groovy.runtime.GStringImpl) values: [Environment Sensor EX - Office] Possible solutions: lastDeviceHumid(java.lang.Object) (lastDeviceHumidity)

Device in question is one of @iharyadi's sensor boards. Average temp and humidity still appear to be working.


#130

There is a typo on line 124 of the driver
def lastDeviceHumid(dev2)

Should be

def lastDeviceHumidity(dev2)

JUST that entry, further entries are ok

I’ll post an updated ver tomorrow

Andy


#131

Thanks Andy, much appreciated.


#132

Did changing that line fix things?


#133

Updated github with ver 1.3.3
With the line 124 fix

Andy


#134

Just created an Average all for temps in the house. Was not able to use a virtual device with the DH selected as a "virtual temperature sensor" had to make my virtual device a "virtual thermostat" for it to show up in the list. Hope that made sense.


#135

Did you use the ‘average all’ device?
This IS a virtual temp device not a thermostat.
However; I believe the HE virtual thermostat can also be used as the target as I changed the commands to accept this at the request of one user.

The only issue was the ‘lastdevice’ command being sent to the device.
The thermostat does not have it so will error in the logs

Andy


#136

So that's what I was trying to say. I first created a virtual temp device. Then when I went to create a average all the newly created virtual temp device did NOT show up in the list for me to select it. HOWEVER when I changed the newly created virtual temp device to a virtual thermostat device....I could choose it.


#137

I understand what you have done. @deanturner39 uses the same thing further up this thread.
What app were you using that needed a thermostat rather than a temperture sensor?


#138

I don't think you are understanding. I first created an virtual temp sensor called "vTemp House Average" Then I went into average all to create the app. however when I got to the part to pick the virtual sensor, "vTemp House Average" did NOT show up in the list. I went back and forth a few times resaving the vTemp sensor thinking maybe it just didn't update yet. No luck. I then CHANGED "vTemp House Average" to a virtual thermostat and then in your app when I went to pick the virtual sensor it was in the list.


#139

Ok.
What driver did you use for ‘vTemp House Average’ when you first created it?
Did you use my average device driver?

Andy


#140

ahhhh, no. I used the built in "Virtual Temp sensor"


#141

I’m pretty sure it says everywhere you must use my driver.. which was written specifically for this app! :wink: :


#142

So that is my problem. You need to add instructions about this driver to the Average All page on your new website. I tried every different temp driver I could find to get ride of the error.


#143

You are right!
Although this is made clear on the release thread on the forum, it's not clear on the website.
I'll speak to @royski to get something like ' you must use the average all driver with this app' and maybe a link to the driver added to the web page

Andy