Unable use commands for Leviton DZPD3

I Had a Wink 2 Hub and had to disconnect it because of them having long outages lasting over 3 weeks so I got feed up and decided to go with Hubitat. I have 5 DZPD3 Plug-in Dimmers. And I was able to added them successfully but in the device section it is not giving me the option to turn them on and off. It just says refresh. I've successfully reset each dimmer to factory and exclusion, attempted to readd them as DZ6HD as recommended in other trends but Im having the same issue. I was reading That I may need to install drivers if so what drivers do I need to install. The hubitat platform is completely different than Wink and I feel like Im getting a little over my head - Any recommendations would be greatly appreciated!!

These are the built-in drivers for Leviton on HE...if others have used the driver you note, then it should work. If you select that driver (Leviton DZ6HD below) and click "Save" then you don't see a "Configure" button (along w/other on/off controls) at the top of the device page? If you do, hit the Configure button and then the device should be controllable from the Device page.


Post a picture of the driver being used on the Device page for the plugs...

This section showing "Type *."

1 Like

Wink survivor here too. Welcome! You'll be glad you came. The Hubitat platform is completely different and there is a learning curve but oh boy is it worth it! Once I got used to the nuances it's great, and the community support is awesome. Not saying you won't have issues, things still go wrong, but HE is REALLY quick to fix bugs and new features are released all the time.

Here's a quick link put together by @rlithgow1 and @neonturbo. It's got some helpful info and video links. And feel free to search the forums and ask the community for help. There's a whole bunch of us here and more arrive every day, so you'll find lots of advice and assistance.


Aaaand then there's this too...


That thread has one person saying they are using the Generic Z-Wave Dimmer driver w/the plug successfully, and another saying that the Leviton DZ6HD driver works. So either of those should work here as well...


Thanks for all the feedback.
I've selected the Leviton DZ6HD but its still not showing commands to operate the dimmer. I also have Hue devices connected and they were able to sync up with the Hue Bridge just fine. Im going to have to play with the Dashboard some more to get that all figured out. I was under the impression that once I add a light or device will automatically be added to the dashboard. Im sure I'll love the Hubitat Hub after I get it all figured out but as of right now I
!'m Lost on why my Leviton Devices not syncing up correctly. This is going to be a huge learning curve. I feel like a need to me CompTia certified. LOL

I wish that was the case. LOL

Is there a Configure button on the device settings page? Did you hit that button after changing drivers?


Which DZPD3 do you have? The original (zwave) one, or the updated z-wave+ version. Depending on which version you have, you'll need to use a different driver.

Here are the zwavealliance pages for each of the two versions:



The problem you're encountering is because you're using z-wave+ drivers for a unit that is just original z-wave (or possibly vice-versa).


That is not correct. You have to build dashboards. That is the nice thing compared to Wink, you are in full control of whether you want something on a dashboard, which dashboard (you can have multiple) and if it is available locally on your network, remotely, or both.



And a video:


I forget the exact issue now (been awhile) but I have the + version (0x5E cluster) of this dimmer and am using the non-smart driver. While it worked with the smart version it didn't report state correctly... or? :thinking:
Anyway, just to mention that you might just try both versions if one is giving you issues. :upside_down_face:



Good point, @Ranchitat.

@user1737 - what do you see in the "Data section of the Device page for the plugs:

Does the "inClusters" line start with "0x5E" or "0x26"?

Knowing which one it is (Z-Wave is 0x26 and Z-Wave+ is 0x5E) might help w/the troubleshooting drivers.

And just to confirm - no matter what driver you try, you have not seen a "Configure" button at the top of the Device page after saving the driver change? Would look like this:

Are you hitting the "Save Device" button at the bottom of the page after you change the driver:

Lastly, can you take a screen shot of the plugs on your Z-Wave Details page? Settings>Z-Wave Details (looks like this):

@bobbyD Can we check to see if the built in drivers have the correct fingerprints for the 2 different models of DZPD3 on the correct drivers? @aaiyar linked the certification for each above. This issue has come up several times so it seems like maybe they are not mapped correctly?

Also, is it possible for us query (either on the hub or on a support site) what a fingerprint will map to without having to go thru an include process with the actual device?


From what I know, they use the clusters of a device as the determining factor to which driver is used. You would need all the clusters from the device, and a database to compare to. I am not sure how you would do the first step without pairing/inclusion?

Leviton has many devices with the same name but are different devices. There are bound to be issues. Why companies do that crap I will never know. But I do think it warrants a look in the backend to see if there is something going on.

It should also be able to use the manufacturer, model and product ID's as reported from the device, where its reported . Clusters can be compared too, I believe. It likely worked similar to ST and all that was part of the z-wave fingerprint there.

For instance, for Inovelli:
fingerprint mfr: "031E", prod: "0003", deviceId: "0001", inClusters:"0x5E,0x26,0x70,0x85,0x59,0x55,0x86,0x72,0x5A,0x73,0x98,0x9F,0x6C,0x75,0x22,0x7A"

My point was several of the forum members could key in their details from an included device (you have one model) and make sure it maps correctly to help others in the future. :slight_smile:

Edit: It looks like the extended manu-productIdType-productId reports are a zwave plus enhancement (manufacturer specific report).
So I'm guessing for the DZPD3-2 (zwave plus), the correct driver could include the fingerprint for 0x001D 0x3501 0x0001. The DZPD3-1 (non zwave plus) would just have to match to the other driver by cluster 0x26 fingerprint inClusters: "0x26"

1 Like