Unable to Z-Wave include Heatit Z-TRM3 Thermostat

So I am fairly new to Hubitat (3 months in now) and I have a fairly well established Zigbee network with 35 devices mixing innr & Hue bulbs, innr and Ikea plugs, Sonoff sensors and switches. It's great and has resulted in me getting rid of all my WiFi cheap devices so really happy.

Today I received a new Heatit Z-TRM3 thermostat for my Kitchen underfloor heating which I have wired in and managed to turn on successfully. It even works with the existing under-floor temperature sensor. All good.

Then comes to Z-Wave inclusion. I started with a basic inclusion. Get onto the hub, start the inclusion process, go through the device menu and start it's "Con" mode, see whirling symbol for 20 seconds (rather than the 90 the manual says to expect) and error on the controller, nothing detected on the Hubitat.

Attempt 2.
Go through the mobile app, Z-Wave tools, Scan QR code for SmartStart. Power off the thermostat, power on, Repeat detection process.

Nothing detected and still "Err" shown on the controller.

So now I get paranoid, controller clearly shows 868.4Mhz frequency on it;s spec sheet. I am in the UK with the Z-Wave region configured to "Europe" on the Hubitat hub.

Am I missing something? Are there any steps I should take to get the hub to detect?

I have previously included 2 other Z-Wave devices however these are currently offline due to issues with the building wiring. Could that be causing my issues?

Thanks in advance.

Hub version
Drivers for this controller added natively in 2.2.5

So an update. I managed to re-connect one of my offline z-wave devices over the weekend and magically this morning the Heatit device appeared in my device list as a secure device. It all appears to be working as one would hope.

I hope this helps someone else.

1 Like

David, does the heat setpoint function correctly on your unit? In other words, are you able to use this to set the temperature you desire? I have a dozen of these devices in my home, all of which connected properly and otherwise work well- but the heating setpoint input does nothing. Might be true of the cooling setpoint as well but that's probably of no more concern to you in West Yorkshire as it is to me in Shropshire!

I have had real problems with the one device I have and will NOT be buying more the same. At the moment the deice is powered off at the breaker and my z-wave network is more reliable than it's ever been.

In terms of automations whilst the z-wave network was working they seemed to be OK. My advice would be to keep the automations as simple as possible. Only change one setting per automation. I found trying to set the heating point to 16 never worked, but 16.5 was OK. that therefore became my overnight setting. If you try and set the mode and setpoint at the same time it invariably failed.


Messed up mesh became un-messed up mesh!

This seems to be my life at the moment. Every time I think the mesh is stable and working it randomly stops, then starts again, then stops. With NO information in the hub logging as to why (I find HE z-wave logging to be epicly useless). First time I know it's not working is when a light does not turn on/off based on an automation.

I have not yet excluded the Heatit Z-TRM3 from the mesh, but will be soon (it's been powered off at the breaker for nearly a month now) as that seems to have improved the reliability of the mesh for other devices.

Going back to the question from @Smokie the device or driver certainly has some quirks and my advice would be to test all commands individually before adding to an automation, and for all automations keep them as simple as possible. One change on one device at a time.

Lots of other threads on the mesh issue but I wonder if you have some mis-performing device that is also a repeater? When it stops your mesh goes to mush, so to speak. And then when it comes alive again your mesh solidifies. Just a theory.

I use Hubitat Z-Wave Mesh Details (available in HPM). It allows you to sort and filter the zwave details info, and more important, allows you to easily see what devices are acting as repeaters for what. That app might be helpful to run when you're having an issue and when you're not and compare.

Thank you for the thoughts.

I also use the Z-Wave Mesh Details app and it seems to show an ever changing set of details as to which devices route through which devices. FYI: all my z-wave devices are mains powered, and the only one which was not a repeater is the Heatit Z-TRM3.

This thread has all the details of my devices:

David, regarding the heating setpoint issue, I tried the value 16.5C as you used and it worked! I experimented and discovered that Centigrade temperature values ending in .5 degrees work fine, just not in whole degrees. I have not tries this in Fahrenheit yet but will guess there's an input validation or conversion function not working quite right yet.

1 Like