Unable to remove device from zwave settings

Also from my screencap above not sure about what the A5 in the routes mean..

???

and as an aside device 0x0D (13) is almost next to the hub - it's a light switch just outside the closet (with no door currently) where the hub is located. Very odd routing that maybe will change by tomorrow.

1 Like

My ghost is on A5...no idea if that is significant or not. It's the only device showing A5 in my device list.

1 Like

I'd really like to clean things up and start over myself (exclude all my Zwave devices and radio reset, then re-include), but I absolutely do not want to waste any more of my time, if I'm going to end up having issues crop up again anyway. C5 users are starting to report zwave problems on their hubs as well w/2.2.3.135, no ghosts involved, so there is more going on w/the Zwave problems that ghosts.

Wish I had waited a few more months before moving over from ST...I was one of the lucky ones there who had zero issues, really fast response, etc. Oh well, have to sleep in the bed I made, I knew the C7 was a new hub, just badly underestimated the initial growing pains that would come with it.

Yeah I only had a one-off issue on my C5 - hasn't been a problem since I restored and re-upgraded (and newer updates). My C4s seem to work okay.

There is no guarantee that starting over with a clean slate will actually work like you want as that is exactly what I did today. I would probably try and pair your new usb stick and see if you can't resolve things that way first.

If you can't pair then you are stuck resetting or waiting until HE has a fix...

When I came over from ST a couple of years ago there were also major teething pains.. I had to exclude/include 80 or so devices like twice and redo all the rules back then... kind of sad really.

1 Like

Youch!

UZB stick arrives Saturday, so I'll be spending part of that day seeing if that helps. I'll also apply any FW updates released, can't get any worse than not working at all. :slight_smile:

Unknown state is not an issue. If you refresh them you will see a state. If you don’t, your mesh might not be strong enough.

Cross check this by actually using the zwave device.

There are many factors involved with zwave such as interference, mesh signal, signal hops etc.

1 Like

Don't. It probably won't work. Check with support if you decide to do this. They put up a warning a while back about doing resets to fix these issues, and generally speaking a hub reset accomplishes nothing except making you re-add everything.

You can say that again! I think the Hubitat team is thinking the same thing right about now!

I have little doubt it will get ironed out soon. As to what soon means, who can tell. But unlike a lot of other hubs, they do put out very fast fixes and do listen to the users. I know they are working literally around the clock to track this down.
:flushed: :nerd_face:

3 Likes

So just wait it out until they address the issues? Family not happy that all the Alexa voice controls no longer work. Most of my Zwave devices now show unknown and many no longer work. Everything worked great on my old C3 hub.

I am not saying to do nothing, but a full reset most likely won't fix it. More that there may be a combination of things it takes to get it up and running. I was suggesting that some of that may be waiting for fixes, but not everything will.

For example, I would see if a controlled shut down, pull the power for a while, and then power on boot helps anything. (not just rebooting) Maybe some of the issues will clear up after the nightly maintenance. I might even be tempted to submit a help ticket if you think there is even a 1% possibility it is a hardware rather than software issue.

You could even have a bad Zwave device killing everything else, and not know it.

I didn't read through your history, so I am not sure what all you have done, but there are some that were able to eventually work though these issues and it was fine after that. So I would keep trying things as people post what worked or helped.

I know it is frustrating, I am having some issues with my hub that I have never seen before in the 18 months or so I have been on here. Luckily I could roll back to a more stable update, not everyone has that option.

1 Like

Ok thanks for the suggestions. I have submitted a support ticket for further assistance. I did try the power down, wait a while, power back up but no luck.

The hardest thing (and I say this to myself as well as my fellow geeks) is to do nothing.

3 Likes

Well I took the jump and did a full reset of the hub. It forced me to inventory all the devices I had, weed out the old non Zwave plus stuff and setup a clean Zwave mesh. The first 20 devices are in and all are a single hop from the Hub except for two of them. I have two GE Zwave plus switches that are connected through another GE Zwave plus switch and operating at 9.6Kbps but they seem to work fine. All the other stuff is running at 100Kbps. Kind of weird those two switches did that since they are the same exact model as all the others (GE ZW4003). I was also able to get rid of the ghost device as well. So far so good...last 13 devices go into tomorrow and then I get to re-write all my rules.

Just to confirm, C7 w/2.2.3.135? Glad to hear of your initial success...and getting rid of the ghost is probably the most important result, according to what HE folks have told me.

Make sure to keep an eye on things the rest of today/tomorrow AM. Depending on FW version I could run upt to 8 or more hours before everything would go to pot and Z-Wave would lock up completely. So good idea to wait until tomorow before putting more work into your setup, as you wouldn't want to have to re-do everything again if your Z-Wave goes wonky.

Yes. C7 with 2.2.3.135.

Same here. I removed all the devices with exclusion, deleted them, removed all the apps, unplugged the hub from power and ethernet, turned off every breaker in the house, waited a full minute turned them all back on, plugged in the hub and now I've got a bunch of unknown devices. I tried excluding them again to no avail and now I have more zombie devices routed through device A5 again.

I'd let it ride for now unless your home automations are critical for some particular reasons. HE should have an updated FW release soon, and in the meantime continued actions w/your hub may just compound your problems.

If you don't want to wait want to try something relatively simple, you could fall back to FW 2.2.3.119, which for several of us has been stable - devices that showed up Unknown and didn't work in later releases show up OK and work in .119.

I know these things can take time, it sounded like the HE team is saying that some z-wave devices don't follow all the protocols.

  • Have they given any indication of a work around for C7 owners?
  • How do I revert back to a previous revision on my C7?
  • Do we have any indication of an update ETA? (I know this may be impossible to answer)

My kids are very unhappy without automation. :slight_smile:

To restore previous FW go to Backup and Restore, and click the "click here" link below, very easy to do;

They don't predict FW releases, but I expect it this week.

It's here! Get this. Been beta testing this and it's been 100% rock solid, and killed the Ghost device that seemed unkillable. Ghost device remained on my Z-Wave Details list, but all routing for it was removed, and suddenly all of my other Z-Wave devices started working and no more Z-Wave busy messages in my logs.

Highly recommended.

4 Likes

Download the Hubitat app