Unable to install xiaomi aqara temperature drivers

I am trying to install the XAOMI drivers in HPM from Jonathan Michaelson but I am getting the following error:

Error Occurred During Installation

An error occurred while installing the package: Failed to install driver https://raw.githubusercontent.com/birdslikewires/hubitat/master/xiaomi/drivers/xiaomi_aqara_temperature_humidity_sensor.groovy. Please notify the package developer..

Did you do that? The package developer would be @birdslikewires. Also make sure you have the latest version of Hubitat Package Manager installed.

As an alternative, you can install the driver using generic instructions for custom driver installation in the Hubitat Documentation.


Hmm, they're @chirpy's so far as I'm aware. Apologies if I've made a mistake on that one, but I've just tried a test install and they don't try to install any of my drivers, so something's awry!

My best guess is that you've tried to install mine by mistake, @user1178. Probably with a version of HPM which doesn't support code libraries. Give HPM an update first and then double-check whose driver you're installing.

I managed to just install the driver manually and so far, it works.