Unable to "find hub"

I previously found and registered the now problematic (model C-7) hub however it stopped working properly after I added a second home's hub to my account (that one works ok). I tried removing non working hub today from my account and rescan using basic and advanced searches, not found. The hub is connected to Ethernet and power,the indicator is green. I then created a new account in order to separate the hubs. Tried searching/adding this hub to the new account - nothing gets found. It's on the same network as my phone. Please advise.

I cannot think of any reason why adding a new hub would interfere with an existing hub. Hub registration is a function of the cloud interface and account management would only affect cloud integrations. If your hub isn't accessible from the local network, and the LED on the hub is green, and Diagnostic Tool isn't accessible then that is indicative of a local network issue. If you'd like, you could send me the MAC address of your problematic hub and I can check if it is connected to the cloud. Additionally, providing more specific details about your network set-up and equipment used may help others understand better the problem you are dealing with.

1 Like

Here is my MAC, #########. This same network was working with no config changes for a couple of years. I can run some network diagnostics if you'd like, lmk which ones and how. Thanks!

There is also the possibility that a router update may have changed settings (if auto update is enabled). And also there is the possibility that the Ethernet port gave up on the hub, or the Ethernet cable went bad. Many variables could play a role when a device stopps communicating within a network.

By the way, I redacted the MAC address, as that is unique to your hub.

1 Like

Checked your hub; it is no longer registered and has not been connected to the cloud since 9/15. Last time it was connected was running version

1 Like

Is there any way to hard reset the hub? What are my options?

If no hub reset options (didn't get the answer to above question) can I return the hub to you folks for a credit so that I can buy the C-8? @bobbyD

My C-7 suddenly (I made no changes) stopped "being found" though it shows green light. I removed it from my account, trying to reset, not finding any way to do it. BobbyD from support disappeared. Should I throw the hub away and get a competitive product or will support suggest a way to reset or recover it?

You can do a network reset using the button on the bottom, which should help your hub become discoverable again on your network if it is otherwise still functional. (Make sure to hold it in long enough, as directed.)

Without cloud connectivity, the automatic options may not work for discovery, but the "advanced" scan options should, or even better is to log in to the admin interface of your router to look at connected devices (any should have a feature like this) and find your hub by name, MAC, or whatever information it offers. That will tell you for sure if it's connected.

If this is related to the other topic you started on the same subject, it seems like you may have some sort of network problem, whether an unusual home setup (multiple VLANs?) or possibly no Internet connectivity for the hub (blocking Internet intentionally, or again maybe a VLAN or guest network kind of thing?). It can work in either setup with proper configuration, but a network reset should get you back if some sort of manual on-hub configuration has you stuck out.


Being able to connect to the hub is also essential to perform a β€œhard” reset or a factory reset, which is what you requested in the other thread you started.

As @bertabcd1234 indicated, past history indicates that the vast majority of reports similar to yours result from network misconfigurations.

Which is not to say that a misconfiguration underlies your specific situation. However, that would be the first thing to rule out.

If you can rule out network issues, you can submit a warranty claim at https://support.hubitat.com, assuming your hub is within the warranty period.


Is there a network or relevant troubleshooting guide?

Most hub network troubleshooting (like seeing if your hub can access the Internet) can be done from Network Settings on the hub. This is in the document I linked to above. However, it requires you to at least be able to connect to the hub on your own LAN first. If you can't do that, you might be dealing with a hub problem, but particularly considering you have a green LED, nearly all of these cases end up being some sort of solvable network misconfiguration on either your hub or your home network. For this reason, I'd start with the network reset on the hub (also the link above).

To troubleshoot your home network, Hubitat might not be the best place to start, but if you share what equipment you're using and any other information about your setup, maybe someone will have some ideas.


You might want to edit your post and delete the mac address.


I don't see an icon or a link on my post to edit the Mac, please do it for me

Do you not see a pencil icon at the bottom right of the post?

No pencil, just the link icon and bookmark icons at the root post of mine

Hmmm .. possibly it is an access thing, i.e. you need to earn a certain trust level in the Discourse platform, but I could be wrong ...

You can join the hub owners group and that should allow you to edit your post to remove your hub’s MAC address.


It helped with MAC edit, thanks!


Has your issue been resolved?