Unable to Clone or Restore rules

Hi all, I changed my phone's name under Devices as well as on the Mobile App and now I am unable to restore any existing rules I had backed up which my phone is part of. I also created a test one which worked as expected but again I backed it up using the Export/Import rule option as well as the Clone one rule but they all failed with the same error.

Capture 2

I also set my phone's name to what it was before and tried the above again but had the same outcome.

Can someone please assist?

Thanks in advance.

I was getting an error while trying to clone a simple rule also.

It started to happen after I installed the latest HE update I think - I am not sure if I renamed my phone before or after that though.

I believe HE support might need to investigate this @bobbyD .

If I can't backup/restore any rules which contain my phone in them then it will be a problem.

I've rolled back to the previous platform version and I now can clone or restore rules as expected so there appears to be an issue with the new build.

I'd done some work yesterday using the new Basic Rules app which is now broken (I can't even uninstall it) but I guess it will only work on the new build.

@bravenel any ETA on the new build/hot fix yet?

I'm on this list as well, can't clone or export/import a rule.

Is anyone able to clone or import/export a rule with the latest firmware.
I guess it's not widespread, but I can not clone or import/export on my C5 or C7 hub.

@bravenel
I did some random testing and concluded a virtual switch will cause it to fail to clone... Should be some help in pinning it down I hope. RM 4.1 on C7@2.2.6.130.
During testing version of RM didn't seem to matter, all failing had virtual switches in my case.
image

@bravenel knows about this bug already. Will be fixed in a hotfix release soon.

Ok. Great I guess, did not say so in this thread though. The power of a bug-tracker... Had saved me some time, ah well.

Saw your post and the rule I had tried to clone and import/export did have virtual switches and virtual shades. I also tried a simple rule on my c7 and it also had a virtual switch, so I thought you might be on to something.

However, I tried a simple rule that turns on lights in a closet and no virtual devices involved would not clone either. Like you all I wanted was confirmation that it was a bug, so I would know just to wait until it was fixed.

1 Like

FYI Looks like this is fixed with the latest hot fix. I was just able to clone a rule.
:+1:

2 Likes

Working as expected now - Thanks a lot to HE support.

2 Likes