Tuya zigbee plug

Seems like a standard on/off reporting... the switch on/off status should be reported correctly with the Generic zigbee outlet driver?

Please do the following:

  1. Make sure the device is configured to use the "Tuya Zigbee Metyering Plug" driver.

  2. Delete the device by pressing the "Remove Device" red button on the device page bottom right corner,

  3. Pair the device again. When the device is discovered, press the 'more' link:

  4. Copy/paste all the information, like in this screenshot:

  5. After saving the detailed device information, press the Save button..

In the AliExpress link that you provided a customer states that this smart plug works with the latest zigbee2mqtt development version, so there shouldn't be a reason to not make it work with HE as well.

2 Likes

thanks for the extended reply.
It was recognized as a


For this plug it is not working.

For an older (also tuya) I have this trick worked fine, so thanks for that

1 Like

@aren there is the xiaomi/aquara motion sensor driver in HPM available. Try that (obviously after installing and switching to the driver, click save then configure..) See if that works for you

I don't understand what you mean. My power plug is recognized as a xiaomi motion sensor. How can another motion sensor driver help me?
I am looking for a driver to switch my power plug on and off, and read my power usage. If I am misreading your reply, please correct me

@aren In hubitat package manager there is a community driver made specifically for that device which may give you what you want.

Weird. From the clusters shown, it should work with the Tuya Zigbee Metering Plug driver written by @kkossev.

@aren I have added your device fingerprint as "Tuya / Neo NAS-WR01" in version 1.1.2 of "Tuya Zigbee Metering Plug" driver. You can update it from HPM or directly from this link.

Please hit the 'Configure' button after updating the driver. Also, make sure your device is actually using this driver:

If after updating and Configuring again the On/Off commands and power/energy readings still do not work, please re-pair the device again to HE hub. I think that repairing again should not be needed, as this is a mains powered zigbee device and the configuration commands should be accepted almost immediately.

@aaiyar The problem seems to be that Markus's driver has the same inClusers and outClusters list, and his driver is selected automatically during the pairing process (probably because this driver was installed earlier than the Tuya driber). Now when this specific device inClusters, outClusters, mode, and manufacturer matches exactly the fingerprint in my driver it should be selected automatically when paired, instead of partially matching Markus driver.

2 Likes

@kkossev thanks for the effort. but I get the same results. these are strange plugs. after changing the driver to your new version. I did not work. I removed the device and re-added it. It was again recognized as a xiaomi sensor. I changed to your driver pressed configure and rebooted the hub. still not working. I checked to see that I use the latest version off the driver. I use 1.1.2.

@aren I think that with a few more iterations we should get it working...

The first problem to solve is to match the correct driver during the pairing process, I see now why my driver fingerprint was not matching - the inClusters list of your device is "0003,0004,0005,0006,0702,0B04,E000,E001,0000", while my device is "0000,0003,0004,0005,0006,0702,0B04,E000,E001". It is one and the same set of clusters, but the two different devices report and HE stores them in a different order. So the simple inClusters string comparison fails. Although the above does not explain why Markus 'Zigbee - Xiaomi/Aqara Motion Sensor' driver is selected instead, the fingerprints there are very different than this Tuya plug...

Just to be sure, can you temporarily change the Tuya plug driver to a "Device" type?
image

Then press the "Get Info" button, copy/paste the text logs for and send the text to me.
Should look like this:

dev:12932021-12-25 16:09:37.293 infofingerprint profileId:"0104", endpointId:"01", inClusters:"0000,0003,0004,0005,0006,0702,0B04,E000,E001", outClusters:"0019,000A", model:"TS011F", manufacturer:"_TZ3000_cphmq0q7"

dev:12932021-12-25 16:09:37.197 traceZCL version:03

dev:12932021-12-25 16:09:37.193 traceSoftware Build Id:unknown

dev:12932021-12-25 16:09:37.188 traceModel:TS011F

dev:12932021-12-25 16:09:37.184 traceManufacturer:_TZ3000_cphmq0q7

dev:12932021-12-25 16:09:36.968 debuggetting info for unknown Zigbee device...

The second problem is that most probably the switch on/off commands are sent to the wrong endpoint/ProfileID (the Zigbee 3.0 'Green Power')... This could be detected and prevented in a future driver version, but I hope that once the correct driver is picked up during the initial pairing process, it will start working OK. At least this was the solution for a similar Tuya plug a month ago.

1 Like

And why again aren't we using the generic zigbee outlet driver with this device?

1 Like

:crazy_face:

"they claim to use the zigbee 3.0 protocol" ..... 'nuff said.

If you had your HE hub updated to version 2.3.0.123 yesterday, you need to revert back to the previous stable version 2.3.0.121

Critical device data like the model, endpointID, etc.. were playing weird today...

Go to HE Settings page -> Check for updates -> downgrade to 2.3.0.121.

The generic zigbee outlet driver should work with this device, with the exception of receiving the power, voltage, amperage data - these Tuya outlets need polling, they can not be configured to send reports automatically.

Thanks for your reply

dev:3682021-12-26 08:49:48.138 traceZCL version:03

dev:3682021-12-26 08:49:48.134 traceSoftware Build Id:unknown

dev:3682021-12-26 08:49:48.129 traceModel:TS011F

dev:3682021-12-26 08:49:48.125 traceManufacturer:_TZ3000_w0qqde0g

dev:3682021-12-26 08:49:48.070 debuggetting info for unknown Zigbee device...

I hope this helps you and of course me :wink:

above was before downgrade.

after downgrade to 2.3.0.121 this is the reply.

2021-12-26 09:01:57.781 debuggetting info for unknown Zigbee device...

dev:4002021-12-26 09:01:55.106 infoZigbee parsed:[raw:00950100060800001000, dni:0095, endpoint:01, cluster:0006, size:08, attrId:0000, encoding:10, command:0A, value:00, clusterInt:6, attrInt:0]

dev:4002021-12-26 09:01:53.966 infoZigbee parsed:[raw:00950100060800001001, dni:0095, endpoint:01, cluster:0006, size:08, attrId:0000, encoding:10, command:0A, value:01, clusterInt:6, attrInt:0]

dev:4002021-12-26 09:01:42.779 debuggetting info for unknown Zigbee device...

I got nothing. with get info. I manually turn the plug on and off. and tried info again.
this is what you get with cheap devices :frowning_face:

'Get Info' is not returning the device fingerprint :frowning:

Most likely the device endpoint is not retrieved and not stored in device Data, this may explain why the inbuilt Generic Zigbee Outlet (and all other drivers) do not work.

Has anyone else seen a similar problem with other zigbee devices?

@kkossev It works !!!
! added a fingerprint profileid in your driver and now it looks like it is working. I can turn the plug on and off. it is recognized when added/discovered
fingerprint profileId: "0104", inClusters: "0003, 0004, 0005, 0006, 0702, 0B04, E001, E000, 0000", outClusters: "0019, 000A", manufacturer: "_TZ3000_w0qqde0g", model: "TS011F", deviceJoinName: "Neo NAS-WR01 Outlet new"
I even get power updates

1 Like

after having it functional with the changed driver. I tried the get info via device again. and now that works also.

2021-12-26 09:27:12.323 infofingerprint profileId:"0104", endpointId:"01", inClusters:"0003,0004,0005,0006,0702,0B04,E001,E000,0000", outClusters:"0019,000A", model:"TS011F", manufacturer:"_TZ3000_w0qqde0g"

dev:4022021-12-26 09:27:12.237 traceZCL version:03

dev:4022021-12-26 09:27:12.229 traceSoftware Build Id:unknown

dev:4022021-12-26 09:27:12.225 traceModel:TS011F

dev:4022021-12-26 09:27:12.220 traceManufacturer:_TZ3000_w0qqde0g

dev:4022021-12-26 09:27:12.153 debuggetting info for unknown Zigbee device...

As all we already know, these Tuya devices behave very weird... So it may be a combination of different factors, such as partially initialized / corrupted device settings inside TS011F firmware. In such cases removing the plug from the mains power supply for a couple of minutes and then re-initializing the devices again may help.

The important thing is that the devices is working now! :slight_smile:

thanks for your great help. :+1: :+1: :+1:

1 Like

There is a new driver version that is published here : [BETA] Tuya Zigbee Metering Plug

Download the Hubitat app